Archicad 28 C++ API
|
Composite fill attribute representation. More...
#include <APIdefs_Attributes.h>
Public Attributes | |
API_Attr_Head | head |
Contains the name and the index of the attribute. The head.flags can be APICWall_xxx . | |
double | totalThick |
Specifies the thickness of the whole wall. | |
short | nComps |
Contains the number of components (simple fills) for the composite. The number of separator lines is nComps+1 because of two contour lines. | |
Composite fill attribute representation.
APICWall_ForWall
, APICWall_ForSlab
, APICWall_ForRoof
and APICWall_ForShell
respectively). You cannot delete the last composite structure. Additional data are assigned to composite fill attributes in the API_AttributeDefExt structure; the definition of a composite fill and separator line is passed through the cwall_compItems
and cwall_compLItems
fields. Refer to the API_CWallComponent and API_CWallLineComponent structures to get more details. Composite structures with negative fill indices are referenced from API_WallType, API_SlabType, API_RoofType, and API_ShellType.