Archicad 28 C++ API
Loading...
Searching...
No Matches
API_AnalyticalCurveMember Struct Reference

Describes an Structural Analytical Model Curve Member. More...

#include <APIdefs_AnalyticalModel.h>

Public Attributes

API_AnalyticalMemberType analyticalMemberType
 The type of the represented element.
 
API_Guid elemGuid
 The unique identifier of the represented element.
 
API_AnalyticalCrossSection crossSection
 The Structural Analytical Model Cross Section type.
 
API_AnalyticalCurve curve
 The curve definition.
 
GS::Array< API_AnalyticalNodeinternalNodes
 List of eventual Internal Nodes set on this Structural Analytical Model Curve Member.
 
double rotationAngle
 The rotation angle.
 
double ey
 The structure eccentricity on the Y axis.
 
API_Vector3D eyVector
 The Y axis of its local coordinate system.
 
double ez
 The structure eccentricity on the Z axis.
 
API_Vector3D ezVector
 The Z axis of its local coordinate system.
 
API_AttributeIndex layerAttrIndex
 The containing layer's attribute index.
 
API_Analytical1DFEMType FEMType
 The FEM type of the curve member.
 
GS::Array< API_AnalyticalVaryingSegmentvaryingSegmentList
 Describes the profiles of the segments, if the Member represents a multisegmented Beam/Column. The sum of the span values of the segments should be equal to 1.
 

Detailed Description

Describes an Structural Analytical Model Curve Member.

Since
Archicad 26