Archicad 27 C++ API
Loading...
Searching...
No Matches
API_UmatType Struct Reference

Representation of a 3D material. More...

#include <APIdefs_3D.h>

Public Attributes

API_3D_Head head
 Header information of this component. This specifies the type and database index.
 
API_MaterialType mater
 The definition of the material. the head.index is 0 in case of GDL materials; and n in case of global material reference.
 

Detailed Description

Representation of a 3D material.

Remarks
This structure contains the properties of a material. These properties are described in API_MaterialType structure. Basically there are two source of materials. First is the globally stored, the second is when they are come from an object's GDL script. In case of GDL materials the index in the header is 0. In case of global material the value of the header is than 0. In both cases the parameters of the material can be obtained from the mater field of this structure. The following 3D components can refer to material: API_PgonType, API_BodyType.