Here is a list of all documented variables with links to the class documentation for each member:
- m -
- main : API_ElemPartId
- mainAxis : API_GridEdgeInfo
- mainaxisFramesLength : API_CurtainWallQuantity
- mainDir : API_GridMeshLine
- mainVersion : API_ServerApplicationInfo
- manual : API_ZoneType
- manualUpdate : API_DrawingType
- manufacturer : API_BuildingMaterialType
- mapId : API_NavigatorItem, API_NavigatorSet, API_NotifyViewEventType
- mapProjection : API_GeoReferenceData
- mapZone : API_GeoReferenceData
- markedDistArea : API_SectionSegment
- markerComponent : API_ChangeMarkerType
- markerData : API_AngleDimensionType, API_DimensionType, API_RadialDimensionType
- markerFont : API_InteriorElevationType
- markerGuid : API_ChangeMarkerType, API_InteriorElevationType
- markerPen : API_InteriorElevationType, API_MarkerData
- markerShow : API_CutPlaneType
- markerSize : API_InteriorElevationType, API_LevelDimensionType, API_MarkerData, API_SectionSegment
- markerTextSize : API_InteriorElevationType
- markerType : API_MarkerData
- markGuid : API_OpeningBaseType
- markId : API_DetailType
- marquee : API_SelectionInfo
- marqueeFilter : API_3DFilterAndCutSettings
- marqueeStory : API_MarqueeFilter
- marqueeType : API_MarqueeFilter
- mask : API_SubElement
- masterColor : API_LayoutsPrefs
- masterLayoutName : API_RVMLayoutInfo
- masterLayoutUnId : API_WindowInfo
- mat : API_ObjectType, API_OpeningBaseType
- mater : API_UmatType
- material : API_Attribute, API_CWFrameQuantity, API_CWFrameType, API_Gable, API_MorphType, API_StairStructureDrainingData, API_ZoneType
- material_cut : API_CWPanelQuantity
- material_inner : API_CWPanelQuantity
- material_outer : API_CWPanelQuantity
- materialAttrIndex : API_AnalyticalSurfaceMember
- materialAttrIndices : API_AnalyticalCrossSection
- materialFrom3D : API_DocumentFrom3DDefaults, API_DocumentFrom3DType
- materialInd : API_MEPSystemType
- materialIndex : API_ElemPartSurfaceQuantity
- materialsChained : API_BeamSegmentType, API_ColumnSegmentType, API_MeshType, API_MonolithStairStructData, API_ShellBaseType, API_SlabType, API_WallType
- matrix00 : API_HatchOrientation
- matrix01 : API_HatchOrientation
- matrix10 : API_HatchOrientation
- matrix11 : API_HatchOrientation
- maxHeight : API_ColumnQuantity, API_ColumnSegmentQuantity, API_WallQuantity
- maxHeightASkin : API_WallQuantity
- maxHeightBSkin : API_WallQuantity
- maxTemp : API_DailyProfile, API_HourlyProfile
- maxTempDef : API_HourlyProfile
- maxTempDefs : API_DailyProfile
- measureType : API_PropertyDefinition
- memberGuid : API_AnalyticalElemPartId
- memo : API_Favorite, API_SubElement
- memoMarker : API_Favorite
- menuItemRef : API_MenuParams
- menuResID : API_MenuItemRef
- mepSystem : API_Attribute
- mesh : API_Element, API_ElementQuantity, API_ElementQuantityMask
- meshEdgesMainAxis : API_GridMesh
- meshEdgesSecondaryAxis : API_GridMesh
- meshLevelCoords : API_ElementMemo
- meshLevelEnds : API_ElementMemo
- meshLinesMainAxis : API_GridMesh
- meshLinesSecondaryAxis : API_GridMesh
- meshPolygons : API_GridMesh
- meshPolyZ : API_ElementMemo
- meshVertices : API_GridMesh
- method : API_ESYMParams, API_GetPolyType, API_IOParams, API_Wrapping
- midC : API_LabelType, API_NoteType
- midCoords : API_AnalyticalCurve
- middleLine : API_SectionSegment
- midMarkerId : API_SectionSegment
- mime : API_PictureType, API_PrimPict
- mimeIn : API_MimePicture
- mimeOut : API_MimePicture
- mimeType : API_PublishFormatData
- mImpl : ACAPI::v1::Object
- minHeight : API_ColumnQuantity, API_ColumnSegmentQuantity, API_WallQuantity
- minHeightASkin : API_WallQuantity
- minHeightBSkin : API_WallQuantity
- minLandingEndEdgeOffset : API_StairPolylineVertexData
- minLandingStartEdgeOffset : API_StairPolylineVertexData
- minOpeningSize : API_QuantityPar
- minTemp : API_DailyProfile, API_HourlyProfile
- minTempDef : API_HourlyProfile
- minTempDefs : API_DailyProfile
- minute : API_PlaceInfo, API_SunAngleSettings
- mirrored : API_PictureType, API_PrimPict
- mirroredLabel : API_LibPartDoorWindowDetails
- mirThick : API_LibPartDoorWindowDetails
- mirThickExpr : API_LibPartDoorWindowDetails
- missingDef : API_LibPart
- missingPict : API_Texture
- model : API_MiscPlotterInfo
- model3D : API_3DStyle
- modelElemPen : API_SectionSegment
- modelElemStructureType : API_AssemblySegmentData, API_ShellBaseType, API_SlabType, API_WallType
- modelOffset : API_DrawingType
- modelUncutSurfBGPen : API_SectionSegment
- modelUncutSurfFillType : API_SectionSegment
- modelUseElemPen : API_SectionSegment
- modelUseUncutSurfFill : API_SectionSegment
- modelViewOpt : API_ModelViewOptionsType, API_NavigatorView, API_ViewOptions
- modelViewOptName : API_NavigatorView
- modified : API_MDCLParameter
- modifiedByUser : API_RVMChange
- modifiedElements : API_ElemDifference
- modiStamp : API_Elem_Head, API_ProjectInfo
- modiTime : API_Attr_Head, API_DimensionStandards_Head, API_MarkUpType, API_ModelViewOptions_Head, API_Pen
- monochromeContourRGB : API_3DStyle
- monochromeEnabled : API_3DStyle
- monochromeSurfaceRGB : API_3DStyle
- monolithPartsVisibility : API_StairStructureComponentSettingsVisibilityOnStory
- monolithStructureSymbolData : API_StairType
- monolithThickness : API_MonolithStairStructData
- month : API_PlaceInfo, API_SunAngleSettings
- morph : API_Element, API_ElementQuantity, API_ElementQuantityMask
- morphBody : API_ElementMemo
- morphingRule : API_RuledShellData
- morphMaterialMapTable : API_ElementMemo
- mtype : API_MaterialType
- multiplier : API_AnalyticalLoadFactor
- multiStory : API_SelectionInfo
- multiStyle : API_TextType
- mustBeTransparent : API_DocumentFrom3DDefaults
- mxValue : API_AnalyticalLink_Rotation
- myValue : API_AnalyticalLink_Rotation
- mzValue : API_AnalyticalLink_Rotation