Archicad 28 C++ API
|
Represents a Stair element. More...
#include <APIdefs_Elements.h>
Public Attributes | |
API_Elem_Head | head |
General element header. | |
double | totalHeight |
The height of the stairs relative to their bottom. | |
double | topOffset |
The offset from top floor if the stairs are top linked. | |
API_LinkToSettings | linkToSettings |
Mode of linking to home story. | |
short | relativeTopStory |
The top linked story (relative to home story). | |
double | flightWidth |
The width of the stairs. | |
UInt32 | stepNum |
The number of steps (risers). | |
UInt32 | nFPDMarkers |
The amount of markers associated to the Stair element on the Floor Plan display. | |
UInt32 | nRCPDMarkers |
The amount of markers associated to the Stair element on the Reflected Ceilind Plan display. | |
UInt32 | treadNum |
The number of treads in this stair. | |
double | riserHeight |
The height of each riser. | |
double | treadDepth |
The length of each going. | |
bool | treadDepthLocked |
Going lengths are locked. | |
bool | totalHeightLocked |
The total height of the Stair is locked. | |
double | walkingLineOffset |
Offset of the walking line, if not centered. | |
API_LinePositionID | walkingLinePosition |
Position of the walking line: |APILP_Left|Offset from the left side.| |APILP_Right|Offset from the right side.| |APILP_Center|Centered.| |APILP_Auto|Automatic (walking lines only).|. | |
bool | extraTopTread |
Extra Top Tread is used to display the top tread. | |
bool | extraBottomTread |
Extra Bottom Tread is used to display the top tread. | |
bool | finishVisible |
Is visibile the Finishing. | |
API_LinePositionID | baselinePosition |
Position of the baseline. | |
double | baselineOffset |
Offset of the baseline, if not centered. | |
API_StairRulesData | rules |
The rules and standards of the stairs. | |
API_StairTreadType | tread [API_StairPartRoleNum] |
Default parameters of treads. | |
API_StairRiserType | riser [API_StairPartRoleNum] |
Default parameters of risers. | |
API_StairStructureType | structure [API_StairPartRoleNum][API_StairStructureSideNum] |
Default parameters of stair structures. | |
API_StairDisplayTypeID | stairDisplayType |
Display type of the Stair: |APIStairDisplay_Custom|Custom display.| |APIStairDisplay_ByModelViewOptions|Display by Model View Options.|. | |
API_StairLayoutData | fpdLayout |
The layout of the Stair element in Floor Plan Display. | |
API_StairLayoutData | rcpdLayout |
The layout of the Stair element in Reflected Ceiling Plan Display. | |
API_StairNumberingID | numberingType |
Type of numbering for each step of the Stair element: |APISN_Treads|Numbering on treads.| |APISN_Risers|Numbering on risers.|. | |
API_StairDirectionID | inputDirection |
The walking direction of the Stair element: |APISD_Upward|Default walking direction (upwards).| |APISD_Inverse|Inverse walking direction (downwards).|. | |
API_Plane3D | basePlane |
The base plane of the Stair subelements. | |
bool | uniformFinish |
Uniform Finish on Flight and Landing. | |
bool | uniformMonolithAttributes |
Uniform Monolithic on Flight and Landing. | |
bool | uniformLeftRightSideSupports [API_StairPartRoleNum] |
Uniform Stringers on Left and Right. | |
bool | uniformDrainings |
Uniform Drainings on Flight and Landing. | |
bool | structureVisibility |
The Structure is visible. | |
API_StairStructureSymbolData | structSymbData [API_StairStructSymbTypeNum][API_StairStructSymbViewNum] |
Stair Structure symbol data for 2D representations. | |
API_StairMonolithStructureSymbolData | monolithStructureSymbolData [API_StairStructSymbViewNum][API_StairStructSymbPartNum] |
Monolith stair structure symbol data for 2D representations. | |
API_StairStructureComponentSettingsVisibility | structureVisibilityOnStories [API_StairStructSymbViewNum] |
Stair Structure symbol visibility for 2D representations. | |
API_StairWalkLineSymbPosID | walkLineSymbPos |
Position of the walking line symbol: |APISP_Auto|Automatic positioning.| |APISP_Center|Centered positioning.| |APISP_Custom|Custom positioning.|. | |
API_StairHeadroomData | stairHeadroomData |
Data of the headroom. | |
Represents a Stair element.
API_StairType::inputDirection |
The walking direction of the Stair element: |APISD_Upward|Default walking direction (upwards).| |APISD_Inverse|Inverse walking direction (downwards).|.
API_StairType::numberingType |
Type of numbering for each step of the Stair element: |APISN_Treads|Numbering on treads.| |APISN_Risers|Numbering on risers.|.
API_StairType::stairDisplayType |
Display type of the Stair: |APIStairDisplay_Custom|Custom display.| |APIStairDisplay_ByModelViewOptions|Display by Model View Options.|.
API_StairType::walkingLinePosition |
Position of the walking line: |APILP_Left|Offset from the left side.| |APILP_Right|Offset from the right side.| |APILP_Center|Centered.| |APILP_Auto|Automatic (walking lines only).|.
API_StairType::walkLineSymbPos |
Position of the walking line symbol: |APISP_Auto|Automatic positioning.| |APISP_Center|Centered positioning.| |APISP_Custom|Custom positioning.|.