Archicad 28 C++ API
Loading...
Searching...
No Matches
API_MaterialType Struct Reference

Description of a surface material attribute. More...

#include <APIdefs_Attributes.h>

Public Attributes

API_Attr_Head head
 Contains the header information, including type and database index.
 
API_MaterTypeID mtype
 The type of the material. Usable values are enumerated in API_MaterTypeID.
 
short ambientPc
 The reflection of ambient light. [0..100].
 
short diffusePc
 The reflection of diffuse light. [0..100].
 
short specularPc
 The reflection of specular light. [0..100].
 
short transpPc
 Transparency factor. [0..100].
 
short shine
 The shininess factor multiplied by 100. [0..10000].
 
short transpAtt
 The transparency attenuation multiplied by 100. [0..400].
 
short emissionAtt
 The emission attenuation factor multiplied by 100. [0..65535].
 
API_RGBColor surfaceRGB
 The color of the surface.
 
API_RGBColor specularRGB
 The specular color.
 
API_RGBColor emissionRGB
 The emission color.
 
API_AttributeIndex ifill
 Internal use.
 
short fillCol
 Color number of defined 3D hatch (<=0 means: use BODY color)
 
API_Texture texture
 The texture of the material.
 

Detailed Description

Description of a surface material attribute.

Remarks
This attribute type is also used by the 3D components. The material of a 3D polygon can be accessed through the API_UmatType structure. There is no additional data assigned to material attributes in the API_AttributeDef structure. Pay attention to the texture member if its fileLoc pointer is dynamically allocadted.