Here is a list of all documented class members with links to the class documentation for each member:
- f -
- f_alpha : API_RGBAColor
- f_blue : API_RGBAColor, API_RGBColor
- f_green : API_RGBAColor, API_RGBColor
- f_red : API_RGBAColor, API_RGBColor
- faceBits : API_DrawingTitle, API_LabelType, API_NoteType, API_PrimText, API_RunType, API_TextType
- facesNr : API_MorphQuantity
- factor : API_AnalyticalLoadFactor
- fbody : API_ElemInfo3D
- fBodyIdx : API_ElemInfo3D
- fElemIdx : API_ElemInfo3D
- FEMType : API_AnalyticalCurveMember, API_AnalyticalSurfaceMember
- figureMode : API_OnScreenViewOptions
- file : API_FileOpenPars, API_FileSavePars, API_PhotoRenderPars
- file_UName : API_LibPart
- fileCreator : API_AttributeManagerFormat
- fileExtension : API_AttributeManagerFormat
- fileExtText2D : API_PublishFormatData
- fileExtText3D : API_PublishFormatData
- fileLoc : API_IOParams, API_Texture
- fileLocation : API_ElemDifferenceGeneratorState
- fileLocOnServer : API_IOParams
- fileSize : API_HotlinkNode
- fileType : API_AttributeManagerFormat
- fileTypeID : API_FileOpenPars, API_FileSavePars, API_IOParams, API_PhotoRenderPars
- fill_lineItems : API_AttributeDef, API_AttributeDefExt
- fill_lineLength : API_AttributeDef, API_AttributeDefExt
- fillAngle : API_MeshType, API_ZoneType
- fillBackgroundPenOverride : API_OverrideRuleStyle
- fillBGPen : API_HatchType
- fillBgPen : API_LabelType, API_MEPSystemType
- fillbkgPen : API_PrimHatchBorder
- fillbkgRgb : API_PrimHatchBorder
- fillCol : API_MaterialType
- fillCutSurfacesWith : API_UniformAttributeOptions
- filldrawingMode : API_OnScreenViewOptions
- filler : API_BeamPart, API_CollisionDetectionSettings, API_CollisionElem, API_ContentPars, API_CWAccessoryQuantity, API_CWJunctionQuantity, API_CWPanelQuantity, API_CWPanelRelation, API_ElemURLRef, API_FloorPlanCutDefinition, API_GDLModelViewOptions, API_LayoutsPrefs, API_LibraryInfo, API_MiscPrinterInfo, API_NavigatorSet, API_OpenLibPartInfo, API_RoomImage, API_RubberArcType, API_RubberLineType, API_RVMDocumentRevision, API_RVMIssue, API_RVMLayoutInfo, API_SkeletonOptions, API_StairRiserQuantity, API_StairTreadQuantity, API_SubSet, API_SunAngleSettings, API_UIStructureDisplay, API_ViewOptions, API_WallPart, API_ZoneAllQuantity
- filler1 : API_PivotPolyEdgeData
- filletRadius : API_RailingRailEndType
- fillExtrArea : API_ZoneAllQuantity
- fillForegroundPenOverride : API_OverrideRuleStyle
- fillInd : API_HatchType, API_MEPSystemType, API_PrimHatchBorder
- fillOverride : API_OverrideRuleStyle
- fillPen : API_HatchType, API_MEPSystemType, API_PrimHatchBorder, API_PrimPoly, API_TextType
- fillRgb : API_PrimHatchBorder
- fillThick : API_CWallComponent
- filltype : API_Attribute
- fillType : API_OverrideRuleStyle
- fillTypeBackgroundPen : API_OverrideRuleStyle
- fillTypeForegroundPen : API_OverrideRuleStyle
- fillVisibility : API_StairStructureComponentSettingsVisibilityOnStory
- filNumb : API_FilltypeType
- filter : API_GetLineType, API_GetPointType, API_GhostRecord, API_GhostStoryType
- filterAndCutSettings : API_DocumentFrom3DType
- filterBits : API_ElemSearchPars
- filterMode : API_3DFilterAndCutSettings
- finalId : API_RVMDocumentRevision
- FinalizeModification() : ACAPI::MEP::v1::CableCarrierSegmentPreferenceTable, ACAPI::MEP::v1::DuctRectangularSegmentPreferenceTable, ACAPI::MEP::v1::ModifiableElementBase, ACAPI::MEP::v1::PortBase, ACAPI::MEP::v1::RoutingElement, ACAPI::MEP::v1::RoutingNode
- FindElementsByGlobalId() : IFCAPI::v1::ObjectAccessor
- FindLibPart() : ACAPI::Library::v1::LibraryManager
- FindLibParts() : ACAPI::Library::v1::LibraryManager
- FindLibraries() : ACAPI::Library::v1::LibraryManager
- FindLibrary() : ACAPI::Library::v1::LibraryManager
- FindViewByGuid : ACAPI::ModelViews::v1::View
- finishDef : API_RailingRailEndType
- finishVisible : API_StairType
- finiteBodyLength : API_OpeningExtrusionParameters
- firstCam : API_CamSetType
- firstExtrusionLength : API_RailingRailConnectionType, API_RailingRailEndType
- firstExtrusionOffset : API_RailingRailEndType
- firstIndent : API_ParagraphType
- firstStory : API_StoryInfo
- firstStory3D : API_3DFilterAndCutSettings
- fitSkylightToCurve : API_PolyRoofData
- fix : API_AnalyticalReleaseDescription
- fixedAngle : API_ObjectType, API_TextType, API_ZoneType
- fixedHeight : API_TextFrameType
- fixedLength : API_AssemblySegmentSchemeData
- fixedPos : API_DimElem
- fixedSize : API_TextType
- fixedWidth : API_TextFrameType
- fixLevel2Absolute0 : API_FloorPlanCutDefinition
- fixMode : API_SkylightType
- fixPoint : API_ObjectType, API_WindowType
- fixPos : API_NoteType
- fixSize : API_LibPartObjectDetails
- fixText : API_PrintPars
- fixtureConnection : API_RailingRailEndType
- fiy : API_AnalyticalReleaseDescription
- fiz : API_AnalyticalReleaseDescription
- flagBits : API_CWallComponent
- flags : API_AddParType, API_Attr_Head, API_CompositeQuantity, API_DimensionStandards_Head, API_Font_Head, API_HatchOrientation, API_HotlinkUserData, API_ModelViewOptions_Head, API_Neig, API_UserData, API_VLNumType, API_Wrapping
- flatNumbering : API_LayoutBook
- flexibleIDs : API_CWSegmentPatternData
- flight : API_ElemInfo3D
- flightWidth : API_StairType
- flipEnabled : API_LabelType, API_TextType
- flipped : API_CurtainWallType, API_CWAccessoryType, API_CWJunctionType, API_DrawingTitle, API_WallType
- float_par : API_MDCLParameter
- floor : API_ClipTran, API_ElemPartId, API_GhostRecord
- floorContLPen : API_ZoneType
- floorContLType : API_ZoneType
- floorDifference : API_HotlinkType
- floorFillBGPen : API_MeshType, API_ShellBaseType, API_SlabType, API_ZoneType
- floorFillInd : API_MeshType, API_ShellBaseType, API_SlabType, API_ZoneType
- floorFillPen : API_MeshType, API_ShellBaseType, API_SlabType, API_ZoneType
- floorId : API_StoryType
- floorIdx : API_SkeletonOptions
- floorInd : API_Elem_Head
- floorNum : API_NavigatorItem
- floorOffset : API_SkeletonOptions
- floorPlanArea : API_MorphQuantity
- floorplanArea : API_ShellQuantity
- floorPlanDisplayMode : API_OpeningFloorPlanParameters
- floorPlanParameters : API_OpeningType
- floorPlanPerimeter : API_MorphQuantity
- floorPlanRotationOrigo : API_DocumentFrom3DType
- floorThick : API_ZoneAllQuantity
- folder : API_Favorite
- font : API_DrawingTitle, API_LabelType, API_PrimText, API_RunType, API_SectionSegment, API_TextType
- fontHeight : API_PrintStampType
- fontID : API_PrintStampType
- foregroundRGB : API_HatchType
- FormatValueToDisplayText() : ACAPI::MEP::v1::ICalculationResultColumn, ACAPI::MEP::v1::TypedCalculationResultColumn< T >
- fpdLayout : API_StairType
- fpedg : API_PgonType
- frame : API_NoteType, API_OpeningExtrusionGeometryData, API_RailingBalusterSetType, API_RailingPanelType
- frameCutLinePen : API_CurtainWallType
- frameCutLineType : API_CurtainWallType
- framed : API_LabelType
- framePen : API_CWallComponent, API_NoteType
- framesLength : API_CurtainWallQuantity
- from : API_ContentPars, API_ParagraphType, API_RunType
- fromDragDrop : API_IOParams
- fromRoom : API_CWPanelRelation
- frontArea : API_StairRiserQuantity
- fullName : API_UserInfo
- function : API_CWPanelQuantity
- fxValue : API_AnalyticalLink_Translation
- fyValue : API_AnalyticalLink_Translation
- fzValue : API_AnalyticalLink_Translation