Here is a list of all documented class members with links to the class documentation for each member:
- i -
- IconContext : INavigatorCallbackInterface
- iconId : API_NavigatorAddOnViewPointData
- iconID : API_PublishFormatData
- IconLinkness : INavigatorCallbackInterface
- IconSize : INavigatorCallbackInterface
- IconTWMode : INavigatorCallbackInterface
- id : API_AddonObject, API_BuildingMaterialType, API_ClassificationItem, API_GridEdgeInfo, API_RVMChange, API_RVMDocumentRevision, API_RVMIssue, API_RVMLayoutInfo, API_ShellContourData
- identification : API_IFCClassificationReference
- idfTypeID : API_DrawingLinkInfo
- ieCreationSegmentDepth : API_SectionSegment
- ieCreationSegmentHorizontalOffset : API_SectionSegment
- iePolygonEdge : API_SectionSegment
- ifill : API_MaterialType
- ignoreSavedZoom : API_NavigatorView
- ignoreTopFloorLinks : API_HotlinkType
- includeBoundingBoxGeometry : API_SavePars_Ifc
- includeInAutoTextsAndIES : API_DrawingType
- inContainsMime : API_MimePicture
- ind1 : API_ChangeParamType, API_PrimText
- ind2 : API_ChangeParamType, API_PrimText
- indent : API_ParagraphType
- index : API_3D_Head, API_AddParType, API_Attr_Head, API_ChangeParamType, API_DescriptorRefType, API_DimensionPrefs, API_DimensionStandards_Head, API_Font_Head, API_GetParamValuesType, API_LibPart, API_ListData_Head, API_MDCLParameter, API_ModelViewOptions_Head, API_Obsolete_ComponentRefType, API_Pen, API_StoryCmdType, API_StoryType, API_TextLinePars, API_WindowInfo
- InEditKeyboardHandler() : Tracking::Tracker::InEditKeyboardHandler
- inEffect : API_LayerCombType
- inEffectForLayout : API_PenTableType
- inEffectForModel : API_PenTableType
- infillPanelID : API_CWSegmentPatternData
- infoTypeID : API_DrawingLinkInfo
- inFrames : API_PersCamSetPars
- inheritEndSurface : API_WallType
- inIndex : API_Base, API_Neig
- Inject() : ACAPI::MEP::v1::Accessory, ACAPI::MEP::v1::Branch, ACAPI::MEP::v1::Equipment, ACAPI::MEP::v1::Fitting, ACAPI::MEP::v1::FlexibleSegment, ACAPI::MEP::v1::RoutingElement, ACAPI::MEP::v1::RoutingNode, ACAPI::MEP::v1::RoutingSegment, ACAPI::MEP::v1::TakeOff, ACAPI::MEP::v1::Terminal
- innerRadius : API_HatchOrientation
- innerReference : API_IFCTranslatorIdentifier
- innerSurfaceMaterial : API_CWPanelType
- innerWidthOffsetType : API_StairPolylineVertexData
- inputDirection : API_StairType
- inputHdl : API_MimePicture
- insetBackSurf : API_ZoneAllQuantity
- insetSideSurf : API_ZoneAllQuantity
- insetTopSurf : API_ZoneAllQuantity
- insulationMatInd : API_MEPSystemType
- insuThickness : API_RoofQuantity, API_ShellQuantity, API_WallQuantity
- intElevSegments : API_ElementMemo
- intendedPlanConn : API_NavigatorItem
- interiorElevation : API_Element
- internalNodes : API_AnalyticalCurveMember, API_AnalyticalSurfaceMember
- interruptOnError : API_ImagingAndCalcPrefs
- intPlanConn : API_DocumentFrom3DDefaults, API_DocumentFrom3DType, API_SectionSegment
- intValue : API_IFCPropertyAnyValue, API_Variant
- invalpointCursor : API_CursorSet
- Invoke() : API_AttributeFolderPicker, API_AttributePicker
- InvokeCalculationResults() : ACAPI::MEP::v1::GraphCalculationInterface
- invtranmat : API_AxonoPars
- ipgon : API_Get3DComponentType, API_GetPointType
- irtxt : API_PgonType, API_Texture
- is3D : API_UIStructureDisplay
- Is3DCutawayEnabled() : ACAPI::Cutaway::v1::CuttingPlane
- isAnalyticalModelVisible : API_AM_VisibilitySettings
- IsAutomaticLabelingOn() : ACAPI::v1::ZoneLabelingSettings
- isAutoOnStoryVisibility : API_BeamType, API_ColumnType, API_CurtainWallType, API_MorphType, API_ObjectType, API_RailingType, API_ShellBaseType, API_StairLayoutData, API_WallType
- isBack : API_StairBoundaryEdgeData, API_StairBoundaryVertexData, API_StairPolylineEdgeData, API_StairPolylineVertexData
- isBottom : API_StairBoundaryEdgeData, API_StairBoundaryVertexData, API_StairPolylineEdgeData, API_StairPolylineVertexData
- IsBuiltIn() : ACAPI::Library::v1::Library
- IsCloser() : Geometry::GJKResult< VectorType >
- IsCollided() : Geometry::GJKResult< VectorType >
- IsContextMenuCommandEnabled() : INavigatorCallbackInterface
- isCreateNewRevision : API_RVMIssue
- isCustom : API_StairBoundaryData, API_StairTreadType
- isCutPlanes : API_3DCutPlanesInfo
- isCutWithFrame : API_DrawingType
- IsDecimalSeparator() : Tracking::Tracker
- isDefault : API_Property
- isDoor : API_CWallPanel
- IsDummyInterface() : INavigatorCallbackInterface
- IsEditable() : ACAPI::Library::v1::GSMObject, ACAPI::MEP::v1::CableCarrierSegmentPreferenceTable, ACAPI::MEP::v1::DuctBranchPreferenceTable, ACAPI::MEP::v1::DuctCircularSegmentPreferenceTable, ACAPI::MEP::v1::DuctElbowPreferenceTable, ACAPI::MEP::v1::DuctRectangularSegmentPreferenceTable, ACAPI::MEP::v1::PipeBranchPreferenceTable, ACAPI::MEP::v1::PipeElbowPreferenceTable, ACAPI::MEP::v1::PipeSegmentPreferenceTable, ACAPI::MEP::v1::ReferenceSetBase, ACAPI::v1::ElementBase
- IsEmbedded() : ACAPI::Library::v1::Library
- isEndWidthAndHeightLinked : API_AssemblySegmentData
- isEnvironmentChanged : API_ElemDifference
- IsEqual() : ACAPI::MEP::v1::ICalculationResultColumn, ACAPI::MEP::v1::TypedCalculationResultColumn< T >
- IsErr() : ACAPI::Result< T, E >
- IsExternal() : ACAPI::v1::ZoneBoundary
- IsFactoryRegistered() : ACAPI::Impl::v1::FactoryRegistry
- IsFirstActivableItemActive() : Tracking::Tracker
- isFlipped : API_BeamType, API_ColumnType, API_ShellType
- isForCabling : API_MEPSystemType
- isForDuctwork : API_MEPSystemType
- isForPipework : API_MEPSystemType
- isFront : API_StairBoundaryEdgeData, API_StairBoundaryVertexData, API_StairPolylineEdgeData, API_StairPolylineVertexData
- isGradient : API_PrimHatchBorder
- IsHierarchicalPagesUsed() : ACAPI::Library::v1::GSMObject
- isHomogeneous : API_AssemblySegmentData
- isIndependent : API_NavigatorItem
- IsInEditMode() : Tracking::Tracker
- isInNumbering : API_DrawingType
- IsInSubTypeOf() : ACAPI::Library::v1::GSMObject
- isLanding : API_StairStructureType
- IsLastActivableItemActive() : Tracking::Tracker
- IsLess() : ACAPI::MEP::v1::ICalculationResultColumn, ACAPI::MEP::v1::TypedCalculationResultColumn< T >
- isLinear : API_PrimHatchBorder
- IsLocal() : ACAPI::Library::v1::Library
- isLocked : API_StairPolylineEdgeData
- isMultiPageDrawing : API_DrawingType
- IsNegative() : API_AttributeIndex
- IsNotFound() : Geometry::GJKResult< VectorType >
- IsOk() : ACAPI::Result< T, E >
- IsOverriden() : API_ExtendedPenType
- isOverrideRevisionId : API_RVMIssue
- IsPackage() : ACAPI::Library::v1::Library
- IsPasswordProtected() : ACAPI::Library::v1::GSMObject
- isPercentFill : API_FilltypeType
- isPersp : API_3DProjectionInfo
- IsPhysicallyConnectable() : ACAPI::MEP::v1::PortBase
- IsPhysicallyConnected() : ACAPI::MEP::v1::PortBase
- IsPlaceable() : ACAPI::Library::v1::GSMObject
- isPlaceable : API_LibPart, API_SavePars_Object
- IsPositive() : API_AttributeIndex
- IsProcessWindowVisible() : API_AddOnCommand
- IsReferenceIdDefined() : ACAPI::MEP::v1::ReferenceSetBase
- IsRoot() : ACAPI::Library::v1::LibraryTreePath
- IsRowValid() : ACAPI::MEP::v1::DuctBranchPreferenceTable, ACAPI::MEP::v1::DuctCircularSegmentPreferenceTable, ACAPI::MEP::v1::DuctElbowPreferenceTable, ACAPI::MEP::v1::PipeBranchPreferenceTable, ACAPI::MEP::v1::PipeElbowPreferenceTable, ACAPI::MEP::v1::PipeSegmentPreferenceTable
- IsRowValidByReferenceId() : ACAPI::MEP::v1::DuctCircularSegmentPreferenceTable, ACAPI::MEP::v1::DuctElbowPreferenceTable, ACAPI::MEP::v1::PipeElbowPreferenceTable, ACAPI::MEP::v1::PipeSegmentPreferenceTable
- IsRowValidByReferenceIds() : ACAPI::MEP::v1::DuctBranchPreferenceTable, ACAPI::MEP::v1::PipeBranchPreferenceTable
- isScheduleAdjusted : API_DrawingType
- IsServer() : ACAPI::Library::v1::Library
- isSizeFixed : API_TextFrameType
- isSlanted : API_BeamType, API_ColumnType
- isStamp : API_PrintPars
- isStatic : API_RailingNodeType
- isStretchable : API_RailingHorizontalPosData
- IsSubType() : ACAPI::Library::v1::GSMObject
- issued : API_RVMChange, API_RVMIssue
- issuedByUser : API_RVMIssue
- issueTime : API_RVMIssue
- isTagTextElemVisible : API_MarkUpType
- isTemplate : API_LibPart
- isTop : API_StairBoundaryEdgeData, API_StairBoundaryVertexData, API_StairPolylineEdgeData, API_StairPolylineVertexData
- IsTrackerEditWindowActive() : Tracking::Tracker
- isTransparentBk : API_DrawingType
- isTwoPointPersp : API_PerspPars
- IsType() : APIVariant< Types >
- IsUIDefault() : ACAPI::Library::v1::GSMObject
- IsVisible() : Tracking::Tracker
- isVisibleOnUI : API_ElemCategoryValue
- isWidthAndHeightLinked : API_AssemblySegmentData
- isWindow : API_CWallPanel
- itemBegAngle : API_LineItems
- itemBegPos : API_LineItems
- itemCenterOffs : API_LineItems
- itemEndAngle : API_LineItems
- itemEndPos : API_LineItems
- itemGuid : API_NotifyViewEventType
- itemID : API_AttributeFolderPickerParams, API_AttributePickerParams, API_UCCallbackType
- itemIndex : API_MenuItemRef
- ItemIterator : Tracking::Tracker
- itemLength : API_LineItems
- itemRadius : API_LineItems
- itemType : API_LineItems, API_NavigatorAddOnViewPointData, API_NavigatorItem
- iumat : API_BodyType, API_PgonType
- ivect : API_PgonType