Archicad 27 C++ API
Loading...
Searching...
No Matches
API_ShellContourData Struct Reference

Shell contour or shell hole contour definition. This structure is used in API_ElementMemo. More...

#include <APIdefs_Elements.h>

Public Attributes

API_Polygon poly
 The dimensions of the variable size polygon data (see API_Polygon).
 
API_Coord ** coords
 Coordinate array.
 
Int32 ** pends
 Polygon endpoints; see API_Polygon for more information.
 
API_PolyArc ** parcs
 Polygon arcs; see API_PolyArc and API_Polygon for more information.
 
UInt32 ** vertexIDs
 Unique identifiers the polygon vertices (unique inside the polygon).
 
UInt32 ** edgeIDs
 Unique identifiers the polygon edges (unique inside the polygon).
 
UInt32 ** contourIDs
 Unique identifiers the polygon contours (unique inside the polygon).
 
API_ContourEdgeDataedgeData
 Data associated to the edges of the contour polygon (see API_ContourEdgeData).
 
API_Tranmat plane
 The contour polygon lies on this plane. The coordinates are given in its 2D coordinate system.
 
double height
 Height (depth) of the cutting body extruded from the hole polygon. Always 0 for the outside contour.
 
UInt32 id
 Id of the hole polygon. Always 0 for the outside contour.
 

Detailed Description

Shell contour or shell hole contour definition. This structure is used in API_ElementMemo.

Remarks
This structure describes the data for the clipping polygon contour (in this case the height and id members are irrelevant), and the hole contours of a shell element.