Archicad 28 C++ API
Toggle main menu visibility
Main Page
Introductory material
General API Development Kit 28
API White Paper
API Compatibility
License Agreement
New API features in Archicad 28
Registration
Technical introduction
Control the Load/Unload Mechanism
Custom panels in settings dialogs
Error Codes
FAQ
GSRoot and STL analogies
Modeless Palettes
Own Data Saved into the Database
Required functions
Required resources
Add-On Management
Library Part Subtypes
Modules
Classes
Class List
Class Index
Class Hierarchy
Class Members
All
a
b
c
d
e
f
g
h
i
j
k
l
m
n
o
p
q
r
s
t
u
v
w
x
y
z
~
Functions
a
b
c
d
e
f
g
h
i
k
l
m
n
o
p
r
s
t
u
w
~
Variables
a
b
c
d
e
f
g
h
i
j
k
l
m
n
o
p
q
r
s
t
u
v
w
x
y
z
Typedefs
Enumerations
Related Symbols
a
c
f
g
s
•
All
Classes
Namespaces
Functions
Variables
Typedefs
Enumerations
Enumerator
Friends
Modules
Pages
Loading...
Searching...
No Matches
Here is a list of all documented class members with links to the class documentation for each member:
- x -
x :
API_Coord3D
,
API_Coord
,
API_VectType
,
API_VertType
x0 :
API_ClipTran
xAxis :
API_CoverFillTransformation
xAxisAbscissa :
API_GeoReferenceData
xAxisOrdinate :
API_GeoReferenceData
xb :
API_Gable
xBeginOffset :
API_RailingFrameData
xe :
API_Gable
xEndOffset :
API_RailingFrameData
xmax :
API_BodyType
xMax :
API_Box3D
,
API_Box
xmin :
API_BodyType
xMin :
API_Box3D
,
API_Box
xRatio :
API_ObjectType
,
API_SyTran
xSize :
API_Texture
xType :
API_AnalyticalSupport_SupportValues
xValue :
API_AnalyticalPointLoad_Settings
,
API_AnalyticalSupport_SupportValues
,
API_AnalyticalSurfaceLoad_Settings
xVector :
API_CoordinateSystem