Here is a list of all documented variables with links to the class documentation for each member:
- s -
- saveDim : API_NavigatorView
- saveDispOpt : API_NavigatorView
- saveDScale : API_NavigatorView
- saveFileIOName : API_IOParams
- saveLaySet : API_NavigatorView
- savePenSet : API_NavigatorView
- saveSelOnly : API_SavePars_Object
- saveStructureDisplay : API_NavigatorView
- saveZoom : API_NavigatorView
- scale : API_ClipTran, API_GeoReferenceData, API_GhostRecord, API_PrintPars, API_RoomImage
- scaleFitToPage : API_PrintPars
- scaleToPaper : API_PrintPars
- scaleType : API_RendImage
- secaxisFramesLength : API_CurtainWallQuantity
- second : API_PlaceInfo, API_SunAngleSettings
- secondExtrusionLength : API_RailingRailConnectionType, API_RailingRailEndType
- secondExtrusionMode : API_RailingRailEndType
- sectBGPen : API_ObjectType, API_OpeningBaseType
- sectContLtype : API_ShellBaseType, API_SlabType
- sectContPen : API_MeshType, API_ObjectType, API_OpeningBaseType, API_ShellBaseType, API_SlabType
- sectElem : API_Element
- sectFill : API_ObjectType, API_OpeningBaseType
- sectFillBGPen : API_SectionSegment
- sectFillPen : API_ObjectType, API_OpeningBaseType, API_SectionSegment
- sectionLineDir : API_ActTranPars
- sectionMarker : API_ModelViewOptions
- sectionSegmentDepthCoords : API_ElementMemo
- sectionSegmentDistCoords : API_ElementMemo
- sectionSegmentMainCoords : API_ElementMemo
- sectPen : API_SectionSegment
- sectType : API_LibPartSection
- segment : API_CutPlaneType, API_InteriorElevationType, API_TestSplineFit
- segmentData : API_CurtainWallType
- segmentedSurfaces : API_RevolvedShellData
- segmentID : API_CWFrameType, API_CWPanelType
- segmentIndex : API_AssemblySegmentProfileData
- segmentRelations : API_BeamRelation
- segmentsByArc : API_PivotPolyEdgeData, API_PolyRoofData, API_RevolvedShellData
- segmentsByCircle : API_PivotPolyEdgeData, API_PolyRoofData, API_RevolvedShellData
- segmentType : API_CWSegmentType, API_PivotPolyEdgeData, API_PolyRoofData, API_RevolvedShellData, API_StairPolylineEdgeData
- sel_nElem : API_SelectionInfo
- sel_nElemEdit : API_SelectionInfo
- selectedSAFTranslatorName : API_SavePars_Saf
- selElemsListing : API_ImagingAndCalcPrefs
- separator : API_ContentPars
- sequence : API_BeamType, API_WallType
- sequenceNumber : API_StairRiserType, API_StairStructureType, API_StairTreadType
- serverApplication : API_ServerApplicationInfo
- serverInfo : API_EnvirParams
- serverSourceLocation : API_HotlinkNode
- setIndex : API_DescriptorRefType, API_ListData_Head, API_ListDataSetType, API_Obsolete_ComponentRefType
- setName : API_ListDataSetType
- setPointValue : API_IFCPropertyBoundedValue
- setWindowSize : API_3DWindowInfo
- setZoom : API_3DWindowInfo
- sfill_Arcs : API_SymbolHatchDef
- sfill_FillCoords : API_SymbolHatchDef
- sfill_HotSpots : API_SymbolHatchDef
- sfill_Items : API_AttributeDef, API_AttributeDefExt
- sfill_Lines : API_SymbolHatchDef
- sfill_PolyArcs : API_SymbolHatchDef
- sfill_SolidFills : API_SymbolHatchDef
- sfill_SubPolys : API_SymbolHatchDef
- shadCont : API_3DStyle
- shadContPen : API_UniformAttributeOptions
- shadFill : API_SectionSegment, API_UniformAttributeOptions
- shadFillBGPen : API_SectionSegment
- shadFillBkgPen : API_UniformAttributeOptions
- shadFillPen : API_SectionSegment, API_UniformAttributeOptions
- shadingPercent : API_3DStyle
- shadowContourThickness : API_3DStyle
- shadowElevation : API_3DStyle
- shapeDirection : API_ExtrudedShellData
- shapePlaneTilt : API_ExtrudedShellData
- shapes : API_3DCutPlanesInfo
- shapeType : API_TextFrameType
- shAppearance : API_SectionSegment
- shell : API_Element, API_ElementQuantity, API_ElementQuantityMask
- shellBase : API_RoofType, API_ShellType
- shellClass : API_ShellType
- shellContours : API_ElementMemo
- shellInsulationFills : API_CalcRulesPrefs
- shellShape : API_ExtrudedShellData, API_RevolvedShellData
- shellShape1 : API_RuledShellData
- shellShape2 : API_RuledShellData
- shellShapes : API_ElementMemo
- shine : API_MaterialType
- shLeftMarkerOffset : API_SectionSegment
- shLeftMarkerOn : API_SectionSegment
- shLineOn : API_SectionSegment
- shLinePen : API_SectionSegment
- shLineType : API_SectionSegment
- shMarkerFaceBits : API_SectionSegment
- shMarkerFont : API_SectionSegment
- shMarkerPen : API_SectionSegment
- shMarkerSize : API_SectionSegment
- shMarkerTextSize : API_SectionSegment
- shouldUseElemPen : API_UniformAttributeOptions
- shouldUseUncutSurfaceFill : API_UniformAttributeOptions
- shouldUseUniformCutAttributes : API_UniformAttributeOptions
- show : API_GhostRecord
- show0Inch : API_LengthDimFormat
- show0Whole : API_LengthDimFormat
- show3DHotSpotsOnly : API_3DStyle
- show_found_poly : API_ZoneType
- showAbove : API_GhostStoryType
- showAllAbove : API_StoryVisibility
- showAllBelow : API_StoryVisibility
- showArea : API_HatchType
- showBelow : API_GhostStoryType
- showColumnSymbol : API_ModelViewOptions
- showContour : API_MorphType
- showContourLines : API_BeamType
- showCutElements : API_SectionSegment
- showDescription : API_StairLayoutData
- showDimensionAllLines : API_OnScreenViewOptions
- showDrawingFrames : API_OnScreenViewOptions
- showExtrudedBodies : API_OnScreenViewOptions
- showFill : API_MorphType
- showFillHandles : API_OnScreenViewOptions
- showFrom : API_PersCamSetPars
- showLines : API_MeshType
- showMarkerRange : API_OnScreenViewOptions
- showMasterBelow : API_LayoutInfo
- showMasterItems : API_OnScreenViewOptions
- showNumbering : API_StairLayoutData
- showOne : API_GhostStoryType
- showOnHome : API_StoryVisibility
- showOpeningCuttingBodies : API_OnScreenViewOptions
- showOpeningReferences : API_OnScreenViewOptions
- showOrigo : API_RadialDimensionType
- showProgressWindow : API_ImagingAndCalcPrefs
- showReferenceAxis : API_BeamType, API_OpeningReferenceAxisParameters
- showRelAbove : API_StoryVisibility
- showRelBelow : API_StoryVisibility
- showRoofPivLine : API_OnScreenViewOptions
- showSkinSeparators : API_OverrideRuleStyle, API_OverrideStyle
- showSmall5 : API_LengthDimFormat
- showSourceMarkerBound : API_OnScreenViewOptions
- showStairHeadroom : API_StairModelViewOptions
- showStructure : API_StairLayoutData
- showTo : API_PersCamSetPars
- showUncutLines : API_BuildingMaterialType
- showUpDownText : API_StairLayoutData
- showWalkingLine : API_StairLayoutData
- shRightMarkerOffset : API_SectionSegment
- shRightMarkerOn : API_SectionSegment
- shSymbolId : API_SectionSegment
- shUseSymbolPens : API_SectionSegment
- side : API_StairStructureType
- sideAngle : API_EdgeTrim
- sideFill : API_MonolithStairStructData
- sideMat : API_MeshType, API_SlabType
- sideMaterial : API_ContourEdgeData
- sideMaterials : API_ElementMemo
- sideType : API_EdgeTrim
- sideWallConLength : API_RoofQuantity, API_ShellQuantity
- sidMat : API_ShellBaseType, API_WallType
- signature : API_ESYMParams
- silhouetteThickness : API_3DStyle
- sillHeight : API_SkylightQuantity, API_WindowQuantity
- sillHeight1 : API_WindowQuantity
- sillHeight2 : API_WindowQuantity
- sillHeight3 : API_WindowQuantity
- singleFile : API_PublishFormatData
- singleValue : API_IFCProperty
- singleVariant : API_PropertyValue
- size : API_RunType, API_TextType
- sizeTo2D : API_LibPartObjectDetails
- sizeX : API_LayoutInfo, API_SavePars_Pdf
- sizeY : API_LayoutInfo, API_SavePars_Pdf
- skeletonOptions : API_DocumentFrom3DDefaults, API_DocumentFrom3DType
- skewAngle : API_RailingSegmentType
- skinAThickness : API_WallQuantity
- skinBThickness : API_WallQuantity
- skipNested : API_HotlinkType
- skipNullFloor : API_StoryInfo
- skirt : API_MeshType
- skirtLevel : API_MeshType
- skylight : API_Element, API_ElementQuantity, API_ElementQuantityMask
- skylightMode : API_ModelViewOptions
- slab : API_Element, API_ElementQuantity, API_ElementQuantityMask
- slabMethod : API_ModelViewOptions
- slantAlpha : API_WallType
- slantAngle : API_BeamType, API_ColumnType, API_CurtainWallQuantity, API_ExtrudedShellData, API_RailingSegmentType, API_RevolvedShellData, API_StairRiserQuantity
- slantBeta : API_WallType
- slantDirectionAngle : API_ColumnType
- smallArc : API_AngleDimensionType
- smoothRidges : API_MeshType
- smoothTarget : API_PersCamSetPars
- snapOffsX : API_GridType
- snapOffsY : API_GridType
- snapStepX : API_GridType
- snapStepY : API_GridType
- softEdgesNr : API_MorphQuantity
- solid : API_PrimArc, API_PrimPoly, API_PrimTri
- solidOperationsOnZones : API_SectionSegment
- sortIndex : API_DrawingType
- source : API_ClassificationSystem, API_IFCClassification
- sourceGuid : API_NavigatorItem
- sourceLocation : API_HotlinkNode
- sourceMarker : API_MarkerLinkDataType, API_SectionSegment
- sourceType : API_HotlinkNode
- spaceAuxX : API_GridType
- spaceAuxY : API_GridType
- spaceMainX : API_GridType
- spaceMainY : API_GridType
- spacing : API_ParagraphType, API_TextType
- spacingFactor : API_NoteType
- span : API_AnalyticalVaryingSegment
- special : API_Base
- specularPc : API_MaterialType
- specularRGB : API_MaterialType
- splCoords : API_TestSplineFit
- splDirs : API_TestSplineFit
- spline : API_Element
- splineMode : API_OnScreenViewOptions
- splittedRoutingElementId : ACAPI::MEP::RouteConnectionResult
- springSettings : API_AnalyticalLink_Settings
- squareRootAngle : API_LabelType
- stair : API_Element, API_ElementQuantity, API_ElementQuantityMask
- stair3DDetailLevel : API_StairModelViewOptions
- stairBaseLine : API_ElementMemo
- stairBoundary : API_ElementMemo
- stairCenterWalkLine : API_ElementMemo
- stairCustomWalkLine : API_ElementMemo
- stairDisplayType : API_StairType
- stairFloorPlanCompDescription : API_StairModelViewOptions
- stairFloorPlanCompNumbering : API_StairModelViewOptions
- stairFloorPlanCompStructureBeamSupport : API_StairModelViewOptions
- stairFloorPlanCompStructureCantilevered : API_StairModelViewOptions
- stairFloorPlanCompStructureStringers : API_StairModelViewOptions
- stairFloorPlanCompTreadAccessories : API_StairModelViewOptions
- stairFloorPlanCompUPDOWNText : API_StairModelViewOptions
- stairFloorPlanCompWalkingLine : API_StairModelViewOptions
- stairFloorPlanVisualization : API_StairModelViewOptions
- stairHeadroomData : API_StairType
- stairModelViewOptions : API_ModelViewOptions
- stairPitchMaxApplied : API_StairRulesData
- stairPitchMaxValue : API_StairRulesData
- stairPitchMinApplied : API_StairRulesData
- stairPitchMinValue : API_StairRulesData
- stairReflectedCompDescription : API_StairModelViewOptions
- stairReflectedCompStructureBeamSupport : API_StairModelViewOptions
- stairReflectedCompStructureCantilevered : API_StairModelViewOptions
- stairReflectedCompStructureStringers : API_StairModelViewOptions
- stairReflectedCompWalkingLine : API_StairModelViewOptions
- stairRiser : API_Element, API_ElementQuantity, API_ElementQuantityMask
- stairRisers : API_ElementMemo
- stairSchemeCutLineIndex : API_StairModelViewOptions
- stairSchemeCutLinePenIndex : API_StairModelViewOptions
- stairSchemeSurfaceIndex : API_StairModelViewOptions
- stairSchemeUncutLineIndex : API_StairModelViewOptions
- stairSchemeUncutLinePenIndex : API_StairModelViewOptions
- stairStructure : API_Element, API_ElementQuantity, API_ElementQuantityMask
- stairStructures : API_ElementMemo
- stairTread : API_Element, API_ElementQuantity, API_ElementQuantityMask
- stairTreads : API_ElementMemo
- stairWalkingLine : API_ElementMemo
- stamp : API_PrintPars
- stampAngle : API_ZoneType
- stampGuid : API_ZoneType
- stampMainGuid : API_ZoneCatType
- stampName : API_ZoneCatType
- stampRevGuid : API_ZoneCatType
- startAt : API_LayoutBook, API_SubSet
- startConnectionType : API_AnalyticalLink_RigidSettings
- startCoord : API_GetArcType, API_GetLineType, API_GetPolyType
- startCoordGiven : API_GetArcType
- startDay : API_DailyProfileUsage
- startElementPartRef : API_AnalyticalLinkType
- startMonth : API_DailyProfileUsage
- startPoint : API_WindowType
- startValue : API_AnalyticalEdgeLoad_Settings
- stateHdl : API_ElemDifferenceGeneratorState
- stateType : API_ElemDifferenceGeneratorState
- staticLevel : API_LevelDimensionType
- status : API_BodyType, API_DescriptorRefType, API_EdgeType, API_GridType, API_LghtType, API_LinkType, API_MarkUpCommentType, API_Obsolete_ComponentRefType, API_PgonType, API_Property, API_RVMDocumentRevision, API_Texture
- stepBeg : API_VLNumType
- stepIndex : API_StairRiserQuantity, API_StairTreadQuantity
- stepNum : API_StairType
- stepVal : API_VLNumType
- stiffnessFix : API_AnalyticalReleaseDescription
- stiffnessFiy : API_AnalyticalReleaseDescription
- stiffnessFiz : API_AnalyticalReleaseDescription
- stiffnessX : API_AnalyticalReleaseDescription
- stiffnessY : API_AnalyticalReleaseDescription
- stiffnessZ : API_AnalyticalReleaseDescription
- storageFormat : API_PictureHandle, API_PictureType, API_PrimPict
- storedInProject : API_DrawingType
- storyInd : API_GhostStoryType
- storyInfo : API_HotlinkNode
- storyRangeType : API_HotlinkNode
- storyRelLevel : API_CurtainWallType
- storyToShowOn : API_CutPlaneType, API_InteriorElevationType
- storyVisibility : API_StairLayoutData
- street : API_ProjectNoteInfo
- stretchedProfile : API_AssemblySegmentProfileData, API_ElementMemo
- string_par : API_MDCLParameter
- stringValue : API_IFCPropertyAnyValue
- structSymbData : API_StairType
- structType : API_StairStructureType
- structure : API_StairType
- structureDisplay : API_NavigatorView, API_UIStructureDisplay
- structureGoingNosingVisible : API_MonolithPartsVisibilityData
- structureGoingVisible : API_MonolithPartsVisibilityData
- structureVisibility : API_StairStructureComponentSettingsVisibilityOnStory, API_StairType
- structureVisibilityOnStories : API_StairStructureComponentSettingsVisibility, API_StairType
- style : API_OverrideRule
- sub : API_ElemPartId
- subElem : API_SubElement
- subElementGuid : API_CompositeId
- subElements : API_Favorite
- subElemFlags : API_SubElement
- subElemId : API_StairBoundaryEdgeData, API_StairBoundaryVertexData, API_StairPolylineEdgeData, API_StairPolylineVertexData, API_StairRiserType, API_StairStructureType, API_StairTreadType
- subFloorThickness : API_OpeningBaseType
- subFolders : API_AttributeFolderContent
- subIdent : API_LibPartSection
- subIndex : API_SubElement
- subPolys : API_RoomReductionPolyType
- subsetId : API_RVMLayoutInfo
- subsetName : API_RVMLayoutInfo
- substituteInd : API_FontType
- subSubIndex : API_SubElement
- subtrColuFlag : API_ZonePrefs
- subtrColuPercent : API_ZonePrefs
- subtrColuSize : API_ZonePrefs
- subtrWallFlag : API_ZonePrefs
- subtrWallPercent : API_ZonePrefs
- subtrWallSize : API_ZonePrefs
- subType : API_FilltypeType, API_Neig, API_SavePars_Ifc, API_SubElement
- subtypeID : API_ObjectSettingsPars
- summerTime : API_SunAngleSettings
- sumTime : API_PlaceInfo
- sunAltitude : API_SunAngleSettings
- sunAngSets : API_AxonoPars, API_PerspPars
- sunAngXY : API_PlaceInfo, API_SectionSegment
- sunAngZ : API_PlaceInfo, API_SectionSegment
- sunAzimuth : API_SunAngleSettings
- sunIntensity : API_SunInfo
- sunPosOpt : API_SunAngleSettings
- sunRGB : API_SunInfo
- sunToAmbient : API_SunInfo
- supersetGuid : API_GDLModelViewOptions
- supplUnId : API_Neig
- supportedMemberPartRef : API_AnalyticalSupportType
- supportSettings : API_AnalyticalSupportType
- supportType : API_AnalyticalSupport_Settings
- supportValues : API_AnalyticalSupport_Settings
- surface : API_AnalyticalSurfaceMember, API_CWPanelQuantity, API_HatchQuantity, API_MorphQuantity, API_ObjectQuantity, API_WindowQuantity
- surface1 : API_WallQuantity, API_WindowQuantity
- surface1_cond : API_WallQuantity
- surface2 : API_WallQuantity, API_WindowQuantity
- surface2_cond : API_WallQuantity
- surface3 : API_WallQuantity
- surfaceMaterial : API_MonolithStairStructData
- surfaceOverride : API_OverrideRuleStyle
- surfaceParam : API_GridMeshVertex
- surfacePoint : API_TexCoordPars
- surfaceRGB : API_MaterialType
- surfaceTolerance : API_CollisionDetectionSettings
- surfaceType : API_AnalyticalSurface, API_OverrideRuleStyle, API_StairStructureDrainingData
- surfSurfCrossCursor : API_CursorSet
- surfSurfNormOnCursor : API_CursorSet
- surveyPointPosition : API_GeoLocation
- suspendFixAngle : API_HotlinkType
- symb : API_ElementQuantity, API_ElementQuantityMask
- symbID : API_RailingBalusterType, API_RailingFinishType, API_RailingHandrailType, API_RailingInnerPostType, API_RailingPanelType, API_RailingPostType, API_RailingRailConnectionType, API_RailingRailEndType, API_RailingRailType, API_RailingToprailType
- symbolFill : API_StairLayoutData
- symbolFillBkgPen : API_StairLayoutData
- symbolFillPen : API_StairLayoutData
- symbolID : API_CWAccessoryType, API_CWFrameType, API_CWJunctionType, API_CWPanelType
- symmetricalLandingOffset : API_StairPolylineVertexData