Here is a list of all documented class members with links to the class documentation for each member:
- o -
- Object() : ACAPI::v1::Object
- object : API_Element, API_LibPartDetails
- ObjectImpl() : ACAPI::Impl::ObjectImpl
- objectType : API_CWFrameType, API_CWPanelType
- objLoc : API_WindowType
- obsolete : API_PetPaletteType
- occupancyCount : API_DailyProfile, API_HourlyProfile
- occupancyType : API_OperationProfileType
- offset : API_BeamType, API_CurtainWallType, API_DrawingType, API_GhostRecord, API_ObjectType, API_RoomImage, API_StairRiserType, API_StairStructureDrainingData, API_StairTreadType, API_WallType
- offsetFromOutside : API_WallType
- offsetFromTop : API_SlabType
- on : API_GhostStoryType
- OnCreated() : API_IObjectEventHandler
- onCutPlaneVisibility : API_UniformAttributeOptions
- OnDeleted() : API_IObjectEventHandler
- oneMat : API_ZoneType
- onlyDimensionText : API_AngleDimensionType, API_DimensionType, API_RadialDimensionType
- OnMarqueeChanged() : API_IMarqueeEventHandler
- OnModified() : API_IObjectEventHandler
- OnResponseValidationFailed() : API_AddOnCommand
- onScreenViewOpt : API_ViewOptions
- OnUserChanged() : API_IGraphisoftIDEventHandler
- OnWindowBroughtForward() : API_IWindowEventHandler
- OnWindowSentBackward() : API_IWindowEventHandler
- op_dailyProfiles : API_AttributeDefExt
- op_dailyProfileUsages : API_AttributeDefExt
- op_hourlyProfiles : API_AttributeDefExt
- opaque : API_NoteType
- openedPath : API_PersCamSetPars
- opening : API_Element
- openingBase : API_SkylightType, API_WindowType
- openingHeight : API_SkylightQuantity
- openingSurf : API_RoofQuantity, API_ShellQuantity
- openingSurface : API_SkylightQuantity
- openingVolume : API_SkylightQuantity
- openingWidth : API_SkylightQuantity
- OpenSettings() : INavigatorCallbackInterface
- OpenView() : INavigatorCallbackInterface
- operationProfile : API_Attribute
- operator bool() : Geometry::GJKResult< VectorType >
- operator!=() : ACAPI::v1::UniqueID, API_AttributeIndex, API_ElemPartId, API_ElemType, IFCAPI::v1::ObjectID
- operator*() : ACAPI::Result< T, E >
- operator->() : ACAPI::Result< T, E >
- operator<() : ACAPI::v1::UniqueID
- operator=() : API_ElemDifferenceGeneratorState, API_ElemType, API_IFCTranslatorIdentifier, API_NavigatorAddOnViewPointData, APIOptional< T >, APIVariant< Types >
- operator==() : ACAPI::Error, ACAPI::v1::UniqueID, API_AnalyticalElemPartId, API_AttributeIndex, API_ElemPartId, API_ElemType, API_InternalAnalyticalMemberPartId, IFCAPI::v1::ObjectID
- oppEndInd : API_WallType
- oppInd : API_WallType
- oppMat : API_WallType
- oppositeSurface : API_ShellQuantity
- oppositeSurface_cond : API_ShellQuantity
- OrElse() : ACAPI::Result< T, E >
- orientation : API_CWFrameType, API_LibPartDoorWindowDetails
- orientationText : API_CWPanelQuantity
- orientPortrait : API_MiscPrinterInfo
- orig : API_PrimArc
- origBox : API_PictureType
- origC : API_ArcType, API_EditPars, API_RubberArcType, API_SFill_Arc
- origin : API_LevelDimensionType
- origo : API_AngleDimensionType, API_CoverFillTransformation, API_GetArcType, API_HatchOrientation
- origoPos : API_ColumnType
- orthogonalHeight : API_GeoReferenceData
- oSide : API_OpeningBaseType
- otherGDLObjectType : API_ProfileAttrType
- Otherwise() : ACAPI::Result< T, E >
- outDepth : API_MimePicture
- outerSurfaceMaterial : API_CWPanelType
- outlineContourDisplay : API_MorphType
- outlinesParameters : API_OpeningFloorPlanParameters
- outlinesStyle : API_OpeningOutlinesParameters
- outputHdl : API_MimePicture
- outResolution : API_RendImage
- overHangType : API_PolyRoofData
- overheadLineIndex : API_OpeningOutlinesParameters
- overheadLinePen : API_CurtainWallType, API_MorphType
- overheadLinePenIndex : API_OpeningOutlinesParameters
- overheadLineType : API_CurtainWallType, API_MorphType
- overheadProjectionMode : API_BeamType, API_CurtainWallType
- overrideCombination : API_NavigatorView
- overrideContours : API_OverrideRuleStyle
- overrideCoverFill : API_OverriddenFillType
- overrideCoverFillFGThickness : API_OverrideStyle
- overrideCutFill : API_OverriddenFillType
- overrideCutFillFGThickness : API_OverrideStyle
- overrideCutSurface : API_OverriddenSurfaceType
- overrideDraftFillFGThickness : API_OverrideStyle
- overrideDraftingFill : API_OverriddenFillType
- overrideLinePenThickness : API_OverrideStyle
- overrideLineType : API_StairLayoutData
- overridePen : API_StairLayoutData
- overridePenColorAndThickness : API_OverrideRuleStyle
- overrideStyle : API_VisualOverriddenImage
- overrideSymbolFill : API_StairLayoutData
- overrideUncutSurface : API_OverriddenSurfaceType
- owner : API_BeamSegmentType, API_ColumnSegmentType, API_CWAccessoryType, API_CWFrameType, API_CWJunctionType, API_CWPanelType, API_CWSegmentType, API_NavigatorItem, API_ObjectType, API_OpeningType, API_RailingBalusterSetType, API_RailingBalusterType, API_RailingFinishType, API_RailingHandrailType, API_RailingInnerPostType, API_RailingNodeType, API_RailingPanelType, API_RailingPatternType, API_RailingPostType, API_RailingRailConnectionType, API_RailingRailEndType, API_RailingRailType, API_RailingSegmentType, API_RailingToprailType, API_SkylightType, API_StairRiserType, API_StairStructureType, API_StairTreadType, API_TextType, API_WindowType
- ownerGuid : API_SectElemType
- ownerId : API_HotlinkNode
- ownerID : API_LibPart
- ownerType : API_ObjectType
- ownPrefix : API_SubSet
- ownUnID : API_LibPart