Archicad 27 C++ API
Loading...
Searching...
No Matches
API_RailingPatternType Struct Reference

Represents a Railing Pattern element. More...

#include <APIdefs_Elements.h>

Public Attributes

API_Elem_Head head
 General element header.
 
API_Guid owner
 The owner railing this pattern belongs to.
 
API_RailingDistributionData distribution
 Describes the distribution of the Pattern's subelements.
 
API_RailingPanelType defPanel
 The default Railing Panel element, from which the Railing Panel instances will be generated.
 
API_RailingBalusterSetType defBalusterSet
 The default Baluster Set element, from which the Baluster Set instances will be generated.
 
API_RailingInnerPostType defInnerPost
 The default Inner Post element, from which the Inner Post instances will be generated.
 
UInt32 nPanels
 Amount of Railing Panels in the Railing Pattern.
 
UInt32 nBalusterSets
 Amount of Baluster Sets in the Railing Pattern.
 
UInt32 nInnerPosts
 Amount of Inner Posts in the Railing Pattern.
 

Detailed Description

Represents a Railing Pattern element.