Here is a list of all documented variables with links to the class documentation for each member:
- r -
- r : API_ArcType, API_PrimArc
- radial : API_DimensionPrefs
- radialDimension : API_Element
- radii : API_RubberArcType
- radius : API_AngleDimensionType, API_LghtType
- railEndFillet : API_RailingRailConnectionType
- railEndOffset : API_RailingRailConnectionType
- railing : API_Element, API_ElementQuantity, API_ElementQuantityMask
- railing2DDisplayCompBalusters : API_RailingModelViewOptions
- railing2DDisplayCompHandrails : API_RailingModelViewOptions
- railing2DDisplayCompInnerPosts : API_RailingModelViewOptions
- railing2DDisplayCompPanels : API_RailingModelViewOptions
- railing2DDisplayCompPosts : API_RailingModelViewOptions
- railing2DDisplayCompRails : API_RailingModelViewOptions
- railing2DDisplayCompTopRail : API_RailingModelViewOptions
- railing3DDetailLevel : API_RailingModelViewOptions
- railingBaluster : API_Element, API_ElementQuantity, API_ElementQuantityMask
- railingBalusters : API_ElementMemo
- railingBalusterSet : API_Element
- railingBalusterSets : API_ElementMemo
- railingEndFinish : API_Element
- railingHandrail : API_Element, API_ElementQuantity, API_ElementQuantityMask
- railingHandrailConnection : API_Element, API_ElementQuantity, API_ElementQuantityMask
- railingHandrailConnections : API_ElementMemo
- railingHandrailEnd : API_Element, API_ElementQuantity, API_ElementQuantityMask
- railingHandrailEnds : API_ElementMemo
- railingHandrails : API_ElementMemo
- railingInnerPost : API_Element, API_ElementQuantity, API_ElementQuantityMask
- railingInnerPosts : API_ElementMemo
- railingModelViewOptions : API_ModelViewOptions
- railingNode : API_Element
- railingNodes : API_ElementMemo
- railingPanel : API_Element, API_ElementQuantity, API_ElementQuantityMask
- railingPanels : API_ElementMemo
- railingPattern : API_Element
- railingPatterns : API_ElementMemo
- railingPost : API_Element, API_ElementQuantity, API_ElementQuantityMask
- railingPosts : API_ElementMemo
- railingRail : API_Element, API_ElementQuantity, API_ElementQuantityMask
- railingRailConnection : API_Element, API_ElementQuantity, API_ElementQuantityMask
- railingRailConnections : API_ElementMemo
- railingRailEnd : API_Element, API_ElementQuantity, API_ElementQuantityMask
- railingRailEnds : API_ElementMemo
- railingRails : API_ElementMemo
- railingSchemeCutLineIndex : API_RailingModelViewOptions
- railingSchemeCutLinePenIndex : API_RailingModelViewOptions
- railingSchemeSurfaceIndex : API_RailingModelViewOptions
- railingSchemeUncutLineIndex : API_RailingModelViewOptions
- railingSchemeUncutLinePenIndex : API_RailingModelViewOptions
- railingSegment : API_Element, API_ElementQuantity, API_ElementQuantityMask
- railingSegments : API_ElementMemo
- railingToprail : API_Element, API_ElementQuantity, API_ElementQuantityMask
- railingToprailConnection : API_Element, API_ElementQuantity, API_ElementQuantityMask
- railingToprailConnections : API_ElementMemo
- railingToprailEnd : API_Element, API_ElementQuantity, API_ElementQuantityMask
- railingToprailEnds : API_ElementMemo
- railingToprails : API_ElementMemo
- range : API_ContentPars, API_ParagraphType, API_RunType
- rasterizeDPI : API_DrawingType
- ratio : API_ArcType, API_DrawingType, API_PrimArc
- ratioEdgeData : API_AnalyticalMemberPartRef
- ratioEnd : API_AMPartRefRatioEdgeData
- ratioStart : API_AMPartRefRatioEdgeData
- rcpdLayout : API_StairType
- readOnly : API_IFCAttribute, API_IFCClassificationReference, API_IFCPropertyHead, API_LibraryInfo
- realValue : API_ChangeParamType
- realValues : API_GetParamValuesType
- receiveShadow : API_MorphType
- recurrence : API_DailyProfileUsage
- reducedExtrArea : API_ZoneAllQuantity
- reducementArea : API_ZoneAllQuantity
- reducePercent : API_ZoneType
- ref : API_WindowInfo
- refC : API_DimensionType
- refC3D : API_DimensionType
- refCon : API_IOParams
- refEndInd : API_WallType
- referenceAxisLineTypeIndex : API_OpeningReferenceAxisParameters
- referenceAxisOverhang : API_OpeningReferenceAxisParameters
- referenceAxisParameters : API_OpeningFloorPlanParameters
- referenceAxisPenIndex : API_OpeningReferenceAxisParameters
- referencedSource : API_IFCClassificationReference
- referenceId : ACAPI::MEP::RoutingSegmentCircularCrossSectionData
- referenceLineLocation : API_WallType
- referenceLinePen : API_RailingType
- referenceName : API_IFCClassificationReference
- referencePlaneLocation : API_SlabType
- referenceRay : API_AnalyticalCylinderSurface
- referenceSurface : API_ShellQuantity
- referenceSurface_cond : API_ShellQuantity
- referredDrawing : API_MarkerLinkDataType
- referredPMViewPoint : API_MarkerLinkDataType
- referredView : API_MarkerLinkDataType
- referringLevel : API_MarkerLinkDataType
- referToDrawing : API_MarkerLinkDataType
- refFloorInd : API_HotlinkNode
- refFloorName : API_HotlinkNode
- refFrame : API_CWAccessoryType
- refId : API_DocumentFrom3DDefaults
- refInd : API_WallType
- reflected : API_ArcType, API_ObjectType, API_OpeningBaseType, API_PrimArc
- refLineFlag : API_ZoneType
- refLineLength : API_WallQuantity
- refLineLocation : API_RailingSegmentType
- refLineOnCursor : API_CursorSet
- refLtype : API_BeamType
- refMat : API_WallType
- refPen : API_BeamType
- refPointOnCursor : API_CursorSet
- refPoly : API_ZoneType
- refPos : API_ZoneType
- refSide : API_OpeningBaseType
- relation : API_AnalyticalLoadGroup
- relative : API_RailingRailType
- relativeHomeStoryLevel : API_AssemblySegmentData
- relativeSkewingAngle : API_RailingSegmentType
- relativeTopStory : API_ColumnType, API_StairType, API_WallType, API_ZoneType
- relativeToStory : API_SectionSegment
- releaseDescriptions : API_AnalyticalReleaseType
- releaseVersion : API_ServerApplicationInfo
- relFillsTable : API_IFCRelationshipData
- relinkWallOpenings : API_HotlinkType
- relVoidsTable : API_IFCRelationshipData
- removeLine : API_SavePars_Object
- rendererID : API_RendEffects
- renderingSceneName : API_NavigatorView
- renovationFilterGuid : API_Elem_Head, API_NavigatorView
- renovationStatus : API_Elem_Head, API_Prim_Head
- reportLevel : API_ImagingAndCalcPrefs
- requiredSSALevel : API_AddOnInfo
- resistanceFx : API_AnalyticalLink_Translation
- resistanceFy : API_AnalyticalLink_Translation
- resistanceFz : API_AnalyticalLink_Translation
- resistanceMx : API_AnalyticalLink_Rotation
- resistanceMy : API_AnalyticalLink_Rotation
- resistanceMz : API_AnalyticalLink_Rotation
- reveal : API_WindowType
- revealDepthFromSide : API_WindowType
- revealDepthLocation : API_WindowType
- revealDepthOffset : API_WindowType
- revolutionAngle : API_RevolvedShellData
- revolvedEdgeDatas : API_RevolvedShellData
- rgb : API_Pen, API_ZoneCatType
- rgbColor : API_PrimPoly
- rgr_layer : API_Elem_Head
- ridgesLength : API_RoofQuantity, API_ShellQuantity
- righFram : API_LibPartDoorWindowDetails
- righFramExpr : API_LibPartDoorWindowDetails
- right : API_PrintPars, API_Rect
- rightIndent : API_ParagraphType
- rightLength : API_BeamQuantity, API_BeamSegmentQuantity
- rightMargin : API_LayoutInfo, API_SavePars_Pdf
- rightMaterial : API_BeamSegmentType, API_MonolithStairStructData
- rightPanelID : API_CWSegmentPatternCellData
- rightSurface : API_BeamSegmentQuantity
- rigidSettings : API_AnalyticalLink_Settings
- riser : API_StairType
- riserGoingRatioMaxApplied : API_StairRulesData
- riserGoingRatioMaxValue : API_StairRulesData
- riserGoingRatioMinApplied : API_StairRulesData
- riserGoingRatioMinValue : API_StairRulesData
- riserHeight : API_StairType
- riserHeightMaxApplied : API_StairRulesData
- riserHeightMaxValue : API_StairRulesData
- riserHeightMinApplied : API_StairRulesData
- riserHeightMinValue : API_StairRulesData
- riserPlusGoingMaxApplied : API_StairRulesData
- riserPlusGoingMaxValue : API_StairRulesData
- riserPlusGoingMinApplied : API_StairRulesData
- riserPlusGoingMinValue : API_StairRulesData
- riserPosition : API_StairRiserType
- rLinEndInd : API_WallType
- rLinInd : API_WallType
- role : API_StairRiserType, API_StairStructureType, API_StairTreadType
- rollAngle : API_PerspPars
- roof : API_Element, API_ElementQuantity, API_ElementQuantityMask
- roofClass : API_RoofType
- roofContourDisplay : API_LegacyPrefs
- roofEdgeTypes : API_ElementMemo
- roofInsulationFills : API_CalcRulesPrefs
- roofShellMode : API_ModelViewOptions
- roomBaseLev : API_ZoneType
- roomEdge : API_WallPart
- roomFlThick : API_ZoneType
- roomGuid : API_RoomImage
- roomHeight : API_ZoneType
- roomHeightLimits : API_ZonePrefs
- roomLSize : API_ZoneType
- roomName : API_ZoneType
- roomNoStr : API_ZoneType
- roomRedPercents : API_ZonePrefs
- rooms : API_RoofRelation
- roomSeparator : API_ArcType, API_LineType, API_PolyLineType, API_SplineType
- roomSpecial : API_HatchType
- roomTopOffset : API_ZoneType
- rootGuid : API_NavigatorSet
- rotAng : API_Texture
- rotAngle : API_PictureType, API_PrimPict
- rotation : ACAPI::MEP::Orientation, API_AnalyticalLink_SpringSettings, API_GhostRecord
- rotationAngle : API_AnalyticalCurveMember
- rotationStiffnessVector : API_AnalyticalLinkGeometry, API_AnalyticalSupportGeometry
- roundInch : API_CalcLengthFormat, API_LengthDimFormat, API_WorkingUnitPrefs
- rowAnchor : API_NoteType
- rubberLineInfoProc : API_RubberPolyCallbacks
- ruledEdgeDatas : API_RuledShellData
- ruleMaxApplied : API_StairRulesData
- ruleMaxValue : API_StairRulesData
- ruleMinApplied : API_StairRulesData
- ruleMinValue : API_StairRulesData
- rules : API_StairType
- run : API_ParagraphType
- runningInBackground : API_ServerApplicationInfo
- runVLScriptOnlyOnce : API_LibPartDoorWindowDetails, API_LibPartObjectDetails
- rxType : API_AnalyticalSupport_SupportValues
- rxValue : API_AnalyticalSupport_SupportValues
- ryType : API_AnalyticalSupport_SupportValues
- ryValue : API_AnalyticalSupport_SupportValues
- rzType : API_AnalyticalSupport_SupportValues
- rzValue : API_AnalyticalSupport_SupportValues