Here is a list of all documented class members with links to the class documentation for each member:
- b -
- b : API_Gable, API_GetParamsType
- b1 : API_CWFrameType
- b2 : API_CWFrameType
- backColor : API_GridType
- backgroundColor : API_RoomImage
- backgroundPen : API_NoteType
- backgroundPictOn : API_SavePars_Archive
- backGroundRGB : API_3DStyle
- backgroundRGB : API_HatchType
- base : API_AngleDimensionType, API_DimBase, API_DimElem, API_RadialDimensionType
- baseConnection : API_RailingRailConnectionType, API_RailingRailEndType
- baseHeight : API_MorphQuantity
- baseLevel : API_MorphQuantity, API_ZoneAllQuantity
- baseLine : API_PlaneRoofData
- baselineOffset : API_StairType
- baselinePosition : API_StairType
- basePlane : API_ShellType, API_StairType
- basePoint : API_AnalyticalCylinderSurface, API_AnalyticalPlaneSurface, API_Plane3D
- basePolygonType : API_OpeningExtrusionParameters
- basicValue : API_PropertyDefaultValue
- beam : API_Element, API_ElementQuantity, API_ElementQuantityMask
- beamFlags : API_WallType
- beamHiddenlineUnderSlabs : API_ModelViewOptions
- beamHoles : API_ElementMemo
- beamMethod : API_ModelViewOptions
- beamPart : API_RoomRelation
- beamSegment : API_Element, API_ElementQuantity, API_ElementQuantityMask
- beamSegments : API_ElementMemo
- beamShape : API_BeamType
- beamType : API_ProfileAttrType
- begAng : API_ArcType, API_PrimArc
- begAngle : API_RevolvedShellData
- begArrow : API_ArrowData
- begC : API_BeamType, API_CWFrameType, API_CWSegmentType, API_EditPars, API_ExtrudedShellData, API_LabelType, API_LineType, API_NoteType, API_NumberingGridLine, API_SFill_Arc, API_SFill_Line, API_WallType
- begID : API_GridMeshEdge, API_GridMeshLine
- begin : ACAPI::MEP::FlexibleSegmentPolylineLinePart
- begIndex : API_PolyArc
- begLine : API_SectionSegment
- begMark : API_SectionSegment
- begMarkerId : API_SectionSegment
- begNode : API_AnalyticalCurve
- begPlaneTilt : API_ExtrudedShellData
- begProfile : API_AnalyticalVaryingSegment
- begRel : API_CWFrameType
- begShapeEdgeData : API_ExtrudedShellData, API_RevolvedShellData, API_RuledShellData
- belowLineType : API_LegacyPrefs
- belowViewLinePen : API_BeamType, API_ColumnType, API_OpeningBaseType
- belowViewLineType : API_BeamType, API_ColumnType, API_OpeningBaseType, API_WallType
- BendDefault() : ACAPI::MEP::v1::BendDefault
- bezierDirs : API_ElementMemo
- bezierPath : API_PersCamSetPars
- bitPat : API_FilltypeType
- bkgAsInRendering : API_3DStyle
- bkgEarthRGB : API_RendImage
- bkgPict : API_RendImage
- bkgPictFile : API_RendImage
- bkgPictRect : API_RendImage
- bkgResolution : API_RendImage
- bkgScaleType : API_RendImage
- bkgSkyColor : API_3DStyle
- bkgSkyRGB : API_RendImage
- body : API_Component3D
- bodyFlags : API_ShellShapeData
- bodyIdx : API_Get3DComponentType, API_GetPointType, API_TexCoordPars
- bodyIndex : API_3D_Head
- bodyType : API_MorphType
- boldCutLines : API_OnScreenViewOptions
- boolValue : API_IFCPropertyAnyValue, API_Variant
- borderLineType : API_DrawingType
- borderPen : API_DrawingType
- borderSize : API_DrawingType
- botFram : API_LibPartDoorWindowDetails
- botFramExpr : API_LibPartDoorWindowDetails
- botMat : API_MeshType, API_ShellBaseType, API_SlabType
- bottom : API_PrintPars, API_Rect
- bottomCutBaseStoryRelInd : API_FloorPlanCutDefinition
- bottomCutLevel : API_FloorPlanCutDefinition
- bottomFrameID : API_CWSegmentPatternCellData
- bottomMargin : API_LayoutInfo, API_SavePars_Pdf
- bottomMaterial : API_BeamSegmentType, API_MonolithStairStructData, API_RoofSegmentData
- bottomOffset : API_ColumnType, API_RailingType, API_WallType
- bottomOversize : API_MonolithStairStructData
- bottomRailIndex : API_RailingVerticalPosData
- bottomSurface : API_BeamQuantity, API_BeamSegmentQuantity, API_MeshQuantity, API_RoofQuantity, API_SlabQuantity
- bottomSurface_cond : API_RoofQuantity, API_SlabQuantity
- bottomType : API_StairStructureType
- boundaryDisplay : API_DocumentFrom3DDefaults, API_DocumentFrom3DType, API_SectionSegment
- boundaryFrameData : API_CurtainWallType
- boundaryFramePosition : API_CurtainWallType
- boundaryLineType : API_DocumentFrom3DDefaults, API_DocumentFrom3DType, API_SectionSegment
- boundaryPen : API_DocumentFrom3DDefaults, API_DocumentFrom3DType, API_SectionSegment
- boundarySurface : API_CurtainWallQuantity
- boundedValue : API_IFCProperty
- bounds : API_DrawingType, API_ElemInfo3D
- box : API_Region
- boxRotAngle : API_Region
- breakLineAngle : API_StairLayoutData
- breakLineAngleNumberOfGoings : API_StairLayoutData
- breakLineAngleType : API_StairLayoutData
- breakLineDistance : API_StairLayoutData
- breakLinePositionType : API_StairLayoutData
- buffer : APIVariant< Types >
- buildingMaterial : API_AssemblySegmentData, API_Attribute, API_CWallComponent, API_CWFrameType, API_CWPanelType, API_HatchType, API_MeshType, API_MonolithStairStructData, API_MorphType, API_ShellBaseType, API_SlabType, API_WallType
- buildMatIdx : API_ElemPartSurfaceQuantity
- buildMatIndices : API_CompositeQuantity
- buildNum : API_ServerApplicationInfo
- byLimitLines : API_SectionSegment