API Infrastructure | General infrastructure-level components of the API |
Add-On - Add-On Communication | These functions provide a way for Add-Ons to communicate (pass data, call exposed commands) with one another |
Add-On Identification | Functions related to the unique identification of the Add-On |
Add-On Integration | Functions to integrate the Add-On seamlessly into Archicad. They provide a way for the Add-On install callbacks to various possible events, integrate into existing dialogs (such as the Save and Open dialog) ans so on |
Add-On Lifetime | Functions defining the Add-On's behavior during its lifetime, including the initial registration by Archicad, loading into memory and unloading |
Add-On Objects | Functions for creating, handling and deleting custom (Add-On specific), Teamwork-safe Add-On Objects. These Objects provide a safer way to handle custom data than the legacy ModulData |
Add-On Preferences | Functions for creating, handling and deleting custom (Add-On specific) preferences, which get stored in the project file. Useful for storing Work Environment settings or some inner states of the Add-On which can be read at the next opening of the project |
Analytical Model | Functions related to the Analytical Model |
Attribute Management | Functions related to accessing and manipulating Attribute and the Attribute-related data of elements |
AutoTexts | Functions for manipulating and accessing AutoTexts |
Bodies | This function family gives support to create or modify the body of a morph element |
Categories | Functions related to creating, accessing and manipulating Categories and the category-related data of elements |
Classification Manager | Functions related to accessing and manipulating Classification and the category-related data of elements |
Command Scopes | Functions related to the Command Scopes of Archicad. They provide a way to post Undoable and NotUndoable commands to the message loop |
Curtain Wall | Functions related to Curtain Wall manupulation and creation |
Custom Modul Data | Functions for creating, handling and deleting custom (Add-On specific) Modul Data. Differs from User Data in not being attached to specific elements or element groups. This is a legacy technology, please use Add-On Objects instead |
Custom User Data | Functions for creating, handling and deleting custom (Add-On specific) User Data attached to specific elements or element groups |
Cutaway and Cutting Planes | Functions related to the Cutting Planes (Cutaway) management |
Cutting Plane Management | Functions related to Cutting Planes and cutaways |
Database Manager | Functions related to the Database Manager, creating, manupulating and switching between different databases |
Design Options | Functions related to the Design Options, Design Option Combinations, and Design Option - View connection |
Dialog and Palette integration | Dialog and Palette managent, and Integration to existing dialogs |
Display Order | Functions used to iterate through the elements in the order the server application would draw them onto the display or manipulating this drawing order |
Drawing Manager | Functions related to the Database Manager, creating, manupulating and switching between different Drawing databases |
Drawing Primitives | Functions providing access to the geometrical primitive-level drawing data of elements |
Element Grouping | Functions to create, delete and use groups and sets of different elements |
Element Links | Functions for creating, handling and deleting custom (Add-On specific) Element Links. These links can provide associations between two elements. The advantage of using element linking is that the server application automatically tracks changes in the GUIDs, and updates them accordingly |
Element Manager | To have an overview what the elements are, and how they fit into the entire database please refer to the Element Overview chapter. In these papers only the handler functions are explained in full details |
Element Set | Provides functions to create and handle element sets for any kind of purpose. You may also add custom information to the element set |
Element difference generator | Functions to get the elements which differ between two projects or project states |
Favorite Management | Functions related to accessing and manipulating the Favorites |
Font | Functions for accessing platform independent font wrappers |
Geolocation | Functions related to the manipulation of and accessing the Project Location data and Archicad's related functionalities |
Geometry | Provides functions for geometry related operations |
Graphic Overrides | Functions related to accessing and changing the Graphic Overrides and Graphic Override Combinations |
Hierarchical editing | Functions dealing with Hierarchical Element-specific information, such as Edit Mode, stair solving and so on |
Hotlink Manager | Functions related to the creation, manipulation and management of hotlink modules |
IFC Data Access | Functions related to the IFC model data in Archicad. They provide a way to access imported IFC data of the model, or manipulate the IFC export process runtime |
Input Method | Functions related to input methods in Archicad |
Issue management | Functions exposing the Issue management and BCF import-export functionalities |
Keynote | Functions related to keynotes, and the keynoting workflow |
Library Management | Functions to load, iterate and manipulate libraries and library parts |
Library Part Management | Old functionalities to iterate and manipulate Library Parts. Most of these structures and functions are deprecated since AC 28. It's recommended to use Library Management components instead |
LicenseInfo | Functions providing information about the Archicad product and license |
MEP Element Manager | Functions related to the creation, manipulation and management of MEP (Mechanical, Electrical, Plumbing) elements |
Menu integration | Functions providing a way to integrate the Add-On into the menu structure of Archicad |
ModelAccess API | |
Notifications Manager | Functions related to the use of various notifications of Archicad. They can be used to automatically execute different tasks when a given trigger is executed in Archicad |
Old Listing | The API of the deprecated (legacy) Listing |
Polygons | Functions to change the shape of a polygon. These polygons are always provided through API_ElementMemo |
Process Windows | Functions related to the Process Control (Process Window) |
Project Navigator | Functions related to the iteration and manipulation of the items of the Project Navigator |
Project Operations | Functions related the server application and various project-related events, such as saving or publishing the project |
Project Settings | Functions for managing project settings, such as Grid, Project Notes, tolerances, etc |
Property Manager | Functions related to accessing and manipulating Properties and the category-related data of elements and attributes |
Publisher | Functions for integrating into the publisher or registering new supported file types |
Rendering Scenes and Settings | Functions related to Photorendering |
Renovation | Functions related to accessing and changing the Renovation settings |
Resource handling | Functions providing a way to access the compiled GRC resources of the AddOn. Used to define and read the localized strings and other resources in a platform-independent manner |
Revision Management | The API of the document revision and issue management system. Differs from the Issue Management system, which deals with issues regarding the project and the model |
Selection handling | Functions related to selection and marquee, including selecting elements and listing selected elements or elements included in the marquee |
Sights | Functions related to the handling of various 3D sights |
Survey Points | Functions related to the Survey Point |
Teamwork | Functions exposing the Teamwork functionality of Archicad, including Teamwork project and connection management, rights and permissions management and release/reserve functionalities |
Toolbox | Functions related to the manipulation of, and integrating into the Toolbox |
Tracker API | |
Tracker Manager | In Archicad every input level has a tracker which is called the main tracker |
Unit and image conversion | Functions providing conversion between different measurement units and different image types |
User Identification | Functions related to unique identification of users via their GSID and/or organizations to which they belong |
User input management | Functions providing a way to access existing user input methods or creating custom user input and feedback |
View Handling | Functions related to the View Settings, zoom and various other View-related functionality |
Window Management | Functions related to the Project Windows, such as creating, opening, switching and closing windows |