Here is a list of all documented variables with links to the class documentation for each member:
- c -
- c : API_Gable, API_MeshLevelCoord, API_PrimTri
- c0 : API_LocalCoordsType
- c1 : API_FilltypeType, API_LocalCoordsType, API_PrimLine, API_RubberLineType, API_Sector
- c2 : API_FilltypeType, API_LocalCoordsType, API_PrimLine, API_RubberLineType, API_Sector
- c3 : API_Get3DComponentType, API_LocalCoordsType
- calcArea : API_ZoneAllQuantity
- camera : API_Element
- cameraZ : API_PerspPars
- camGuid : API_3DProjectionInfo
- camId : API_NavigatorItem
- camInd : API_LinkType
- camPathViewMode : API_OnScreenViewOptions
- camset : API_Element
- camSetGuid : API_CameraType
- canValueBeEditable : API_PropertyDefinition
- caption : API_MiscAppInfo
- castShadow : API_MorphType
- castShadowPercent : API_3DStyle
- catCode : API_ZoneCatType
- category : API_AnalyticalLoadCombination, API_CWAccessoryType, API_CWJunctionType, API_CWSegmentType, API_ElemCategoryValue
- categoryID : API_ElemCategory
- categoryText : API_CWFrameQuantity
- catInd : API_ZoneType
- cellID : API_CWFrameType
- centerLength : API_WallQuantity
- centerLinePen : API_MEPSystemType
- centerLTypeInd : API_MEPSystemType
- centerx : API_Beam_Hole
- centerz : API_Beam_Hole
- centroid : API_CWPanelType
- chainBkgColors : API_3DStyle
- changeCursorSet : API_GetArcType, API_GetLineType, API_GetPointType, API_GetPolyType
- changeFilter : API_GetLineType, API_GetPointType
- changeId : API_ChangeMarkerType
- changeMarker : API_Element
- changeName : API_ChangeMarkerType
- changeNumberingStyle : API_LayoutBook
- changePlane : API_GetLineType, API_GetPointType, API_GetPolyType
- changePrefix : API_LayoutBook
- charCode : API_FontType
- charSpaceFactor : API_PrimText, API_TextType
- checkSum : API_GDLModelViewOptions
- checkSumList : API_WindowValidatorInfo
- circle : API_Element
- circleBased : API_AssemblySegmentData
- city : API_ProjectNoteInfo
- clampFrameOrientsNum : API_CWJunctionType
- clampFramesNum : API_CWJunctionType
- clampPanelsNum : API_CWJunctionType
- classID : API_CWFrameType, API_CWPanelType, API_ElemType
- classifications : API_Favorite
- className : API_CWFrameType, API_CWPanelType
- client : API_ProjectNoteInfo
- clipOtherSide : API_DimensionType
- closed : API_SplineType
- cMater : API_DocumentFrom3DDefaults
- cmd : API_PropertyObjectParams
- code : API_DescriptorType, API_KeyType, API_Obsolete_ComponentType, API_ProjectNoteInfo, API_UnitType
- collectionType : API_PropertyDefinition
- collidedElemGuid : API_CollisionElem
- color : API_BodyType, API_EdgeType
- colorDepth : API_PhotoRenderPars, API_PictureType, API_PrimPict, API_SavePars_Picture
- colorMode : API_DrawingType
- colorOverridePenIndex : API_ExtendedPenType
- coluConnPriority : API_LegacyPrefs
- coluExtrArea : API_ZoneAllQuantity
- coluHiddenlineUnderSlabs : API_ModelViewOptions
- column : API_Element, API_ElementQuantity, API_ElementQuantityMask
- columnSegment : API_Element, API_ElementQuantity, API_ElementQuantityMask
- columnSegments : API_ElementMemo
- columnsNumber : API_WallQuantity
- coluType : API_ProfileAttrType
- combination : ACAPI::DesignOptions::v1::DesignOptionCombinationViewSettings::Custom, ACAPI::DesignOptions::v1::DesignOptionCombinationViewSettings::Standard
- company : API_ProjectNoteInfo
- compAutoThick : API_DimensionType
- compLibInd : API_ListDataSetType
- component : API_ListData
- componentGuid : API_ComponentID
- componentID : API_ElemComponentID
- composite : API_ShellBaseType, API_SlabType, API_WallType
- compositeId : API_CompositeQuantity
- composites : API_ElemPartCompositeQuantity, API_Quantities, API_QuantitiesMask
- compositionPriority : API_ShellBaseType
- compWall : API_Attribute
- con : API_BeamRelation, API_BeamSegmentRelation, API_WallRelation
- conBeg : API_BeamRelation, API_BeamSegmentRelation, API_WallRelation
- concaveCorners : API_ZoneAllQuantity
- conClassId : API_LayerStat, API_LayerType
- conEnd : API_BeamRelation, API_BeamSegmentRelation, API_WallRelation
- connected : API_UserInfo
- connectionDetailLinePen : API_StairMonolithStructureSymbolData
- connectionDetailLineType : API_StairMonolithStructureSymbolData
- connectionLinePen : API_StairMonolithStructureSymbolData
- connectionLineType : API_StairMonolithStructureSymbolData
- connectionMode : API_OpeningFloorPlanParameters
- connectionOffset : API_RailingNodeType
- connectionVisible : API_MonolithPartsVisibilityData
- connPoint : API_LinkType
- connPoly : API_BeamRelation, API_BeamSegmentRelation, API_WallRelation
- connPriority : API_BuildingMaterialType, API_CWFrameType
- conRef : API_BeamRelation, API_BeamSegmentRelation, API_WallRelation
- constraint : API_OpeningExtrusionParameters
- constructionElementsOnly : API_DetailType
- constType : API_ConstraintPars
- constValue : API_ConstraintPars
- containmentTable : API_IFCRelationshipData
- Contains : APIVariant< Types >
- content : API_ContentPars, API_NoteType
- contentType : API_NoteType
- contentUStr : API_NoteType
- continueNumbering : API_SubSet
- continuous : API_SectionSegment
- contLtype : API_ColumnType, API_WallType
- contour : API_AnalyticalSurfaceMember, API_SurfaceLoadCustomData
- contourAncestry : API_RegularizedPoly
- contourArea : API_RoofQuantity
- contourFramesLength : API_CurtainWallQuantity
- contourID : API_CWFrameType
- contourIDs : API_ElementMemo, API_RegularizedPoly, API_ShellContourData
- contourIdx : API_InternalAnalyticalMemberPartId
- contourIndex : API_AnalyticalElemPartId
- contourLinePen : API_StairMonolithStructureSymbolData
- contourLineType : API_StairMonolithStructureSymbolData
- contourNum : API_CWSegmentType
- contourOffset : API_LabelType, API_TextType
- contourPen : API_MEPSystemType, API_RailingType, API_TextType
- contourPolygon : API_PolyRoofData
- contours_3D : API_LibPartDoorWindowDetails
- contourSurface : API_CurtainWallQuantity
- contourThickness : API_3DStyle
- contPen : API_HatchType, API_MeshType, API_WallType
- contPen3D : API_WallType
- controlPoints : ACAPI::MEP::FlexibleSegmentPolylineSplinePart
- contureOff : API_DocumentFrom3DDefaults
- convertedValue : API_UnitConversionData
- conWithBeg : API_ConnectionGuidItem
- conX : API_BeamRelation, API_BeamSegmentRelation, API_WallRelation
- coord : API_AnalyticalNode, API_GridMeshVertex
- coordinate : API_AnalyticalPointLoadGeometry
- coordinates : API_AnalyticalLinkGeometry, API_AnalyticalSupportGeometry
- coordinateSystem : API_AnalyticalSupport_Settings
- coordinateSystemType : API_AnalyticalEdgeLoad_Settings, API_AnalyticalPointLoad_Settings, API_AnalyticalSurfaceLoad_Settings
- coords : API_BeamRelation, API_BeamSegmentRelation, API_CWContourData, API_ElementMemo, API_Gable, API_GetPolyType, API_Niche, API_Region, API_RegularizedPoly, API_RoomReductionPolyType, API_ShellContourData, API_ShellShapeData, API_StairBoundaryData, API_StairPolylineData, API_WallRelation
- coreAnchor : API_ColumnType
- coreBotSurf : API_ColumnQuantity
- coreGrossBottomSurface : API_ColumnSegmentQuantity
- coreGrossSurf : API_ColumnQuantity
- coreGrossSurface : API_ColumnSegmentQuantity
- coreGrossTopBotSurf : API_ColumnQuantity
- coreGrossTopSurface : API_ColumnSegmentQuantity
- coreGrossVolume : API_ColumnQuantity, API_ColumnSegmentQuantity
- coreNetBottomSurface : API_ColumnSegmentQuantity
- coreNetSurface : API_ColumnSegmentQuantity
- coreNetTopSurface : API_ColumnSegmentQuantity
- corePen : API_ColumnType
- coreSurface : API_ColumnQuantity
- coreSymbolPar1 : API_ColumnType
- coreSymbolPar2 : API_ColumnType
- coreSymbolPen : API_ColumnType
- coreSymbolType : API_ColumnType
- coreTopSurf : API_ColumnQuantity
- coreVolume : API_ColumnQuantity, API_ColumnSegmentQuantity
- cornerFrameData : API_CurtainWallType
- cornerPointIDs : API_GridMesh
- cosa : API_LghtType
- cosb : API_LghtType
- country : API_ProjectNoteInfo
- coverFillBackgroundPen : API_BeamType, API_ColumnType
- coverFillBackgroundPenIndex : API_OpeningCoverFillsParameters
- coverFillBGPen : API_MorphType, API_OverrideStyle
- coverFillFGPen : API_OverrideStyle
- coverFillForegroundPen : API_BeamType, API_ColumnType
- coverFillIndex : API_OpeningCoverFillsParameters
- coverFillOrientation : API_MorphType, API_OpeningCoverFillsParameters
- coverFillOrientationComesFrom3D : API_BeamType, API_ColumnType
- coverFillPen : API_MorphType
- coverFillPenIndex : API_OpeningCoverFillsParameters
- coverFillsParameters : API_OpeningFloorPlanParameters
- coverFillTransformation : API_BeamType, API_ColumnType, API_OpeningFloorPlanParameters
- coverFillTransformationType : API_BeamType, API_ColumnType
- coverFillType : API_BeamType, API_ColumnType, API_MorphType, API_OverrideStyle, API_RoofSegmentData
- createAtDefaultPosition : API_LabelType
- createdBranchId : ACAPI::MEP::RouteConnectionResult
- creaTime : API_MarkUpCommentType, API_MarkUpType
- criterionXML : API_OverrideRule
- critLibInd : API_ListDataSetType
- crop : API_SavePars_Picture
- crossingFrameID : API_CWSegmentPatternCellData
- crossingFrameType : API_CWSegmentPatternCellData
- crossOnCursor : API_CursorSet
- crossSect : API_StairRiserType
- crossSection : API_AnalyticalCurveMember
- crossSectionAreaCutBegin : API_BeamQuantity, API_BeamSegmentQuantity, API_ColumnQuantity, API_ColumnSegmentQuantity
- crossSectionAreaCutEnd : API_BeamQuantity, API_BeamSegmentQuantity, API_ColumnQuantity, API_ColumnSegmentQuantity
- crossSectionType : API_AnalyticalCrossSection
- currCutLevel : API_FloorPlanCutDefinition
- currentFinalRevisionId : API_LayoutInfo
- currentRevisionId : API_LayoutInfo
- currLandingEndEdgeOffset : API_StairPolylineVertexData
- currLandingStartEdgeOffset : API_StairPolylineVertexData
- currPlanConn : API_DocumentFrom3DType, API_SectionSegment
- cursorSet : API_GetArcType, API_GetLineType, API_GetPointType, API_GetPolyType
- curtainWall : API_Element
- curtainWallExtrArea : API_ZoneAllQuantity
- curtainWallModelViewOptions : API_ModelViewOptions
- curve : API_AnalyticalCurveMember, API_EdgeLoadCustomData
- curveAngle : API_BeamType
- curves : API_AnalyticalLinkGeometry
- custom : API_GetParamValuesType
- customAngle : API_AssemblySegmentCutData
- customBasePolygon : API_OpeningExtrusionGeometryData
- customData : API_LayoutInfo, API_RVMChange, API_RVMIssue, API_RVMLayoutInfo
- customFramesLength : API_CurtainWallQuantity
- customId : API_StairBoundaryEdgeData, API_StairBoundaryVertexData, API_StairPolylineEdgeData, API_StairPolylineVertexData
- customLayoutNumber : API_LayoutInfo
- customLayoutNumbering : API_LayoutInfo
- customMarker : API_MarkerLinkDataType
- customMater : API_3DCutPlanesInfo
- customName : API_NavigatorItem
- customNumber : API_DrawingType, API_SubSet
- customNumbering : API_SubSet
- customOrigProfile : API_AssemblySegmentProfileData, API_ElementMemo
- customParams : API_ElementMemo
- customPen : API_3DCutPlanesInfo
- customScheme : API_LayoutBook
- customText : API_PrintStampType
- customUiId : API_NavigatorItem
- customVertexCoord : API_AMPartRefCustomVertexData
- customVertexData : API_AnalyticalMemberPartRef
- cutaway3D : API_DocumentFrom3DType
- cutBodyType : API_ShellBaseType
- cutContourLinePen : API_BeamType
- cutContourLineType : API_BeamType
- cutElem : API_Gable
- cutFill : API_BuildingMaterialType
- cutFillBackgroundPen : API_BeamType, API_BuildingMaterialType, API_ColumnType, API_CurtainWallType, API_MeshType, API_MonolithStairStructData, API_MorphType, API_ShellBaseType, API_SlabType, API_WallType
- cutFillBGPen : API_OverrideStyle
- cutFillFGPen : API_OverrideStyle
- cutFillOrientation : API_BuildingMaterialType
- cutFillPen : API_BeamType, API_BuildingMaterialType, API_ColumnType, API_CurtainWallType, API_MeshType, API_MonolithStairStructData, API_MorphType, API_ShellBaseType, API_SlabType, API_WallType
- cutFillType : API_OverrideStyle
- cutHeight : API_SkeletonOptions
- cutLinePen : API_CWFrameType, API_CWPanelType, API_MonolithStairStructData, API_MorphType
- cutLineType : API_CWFrameType, API_CWPanelType, API_MonolithStairStructData, API_MorphType, API_OpeningBaseType
- cutMater : API_3DCutShapeType
- cutMaterial : API_BuildingMaterialType
- cutOffset : API_SkeletonOptions
- cutPen : API_3DCutShapeType
- cutPlane : API_Element
- cutPlIdStr : API_SectionSegment
- cutPlName : API_SectionSegment
- cutPlShow : API_CutPlaneType, API_InteriorElevationType
- cutProjectionMode : API_CurtainWallType
- cutSetting : API_DocumentFrom3DType
- cutStatus : API_3DCutShapeType
- cutSurfaceMaterial : API_CWPanelType
- cutSurfacesParameters : API_OpeningFloorPlanParameters
- cutSurfaceType : API_OverrideStyle
- cuttingSurfacePolygons : ACAPI::Cutaway::v1::API_CutPolygonInfo
- cutType : API_AssemblySegmentCutData
- cw : API_ElementQuantity, API_ElementQuantityMask
- cwAccessory : API_Element, API_ElementQuantity, API_ElementQuantityMask
- cwAccessoryDetailLevel : API_CurtainWallModelViewOptions
- cwall_compItems : API_AttributeDef, API_AttributeDefExt
- cwall_compLItems : API_AttributeDefExt
- cWallAccessories : API_ElementMemo
- cWallFrameDefaults : API_ElementMemo
- cWallFrames : API_ElementMemo
- cWallJunctions : API_ElementMemo
- cWallPanelDefaults : API_ElementMemo
- cWallPanelGridIDTable : API_ElementMemo
- cWallPanels : API_ElementMemo
- cWallSegments : API_ElementMemo
- cwFrame : API_Element, API_ElementQuantity, API_ElementQuantityMask
- cwFrameDetailLevel : API_CurtainWallModelViewOptions
- cwJunction : API_Element, API_ElementQuantity, API_ElementQuantityMask
- cwJunctionDetailLevel : API_CurtainWallModelViewOptions
- cwPanel : API_Element, API_ElementQuantity, API_ElementQuantityMask
- cwPanelDetailLevel : API_CurtainWallModelViewOptions
- cWSegContour : API_ElementMemo
- cWSegGridMesh : API_ElementMemo
- cwSegment : API_Element
- cwSegmentPart : API_RoomRelation
- cWSegPatternCells : API_ElementMemo
- cWSegPrimaryPattern : API_ElementMemo
- cWSegSecondaryPattern : API_ElementMemo
- cylinderSurface : API_AnalyticalSurface