Archicad 27 C++ API
Loading...
Searching...
No Matches
API_StairPolylineData Struct Reference

Represents a Stair polyline (baseline or walking line). More...

#include <APIdefs_Elements.h>

Public Attributes

API_Polygon polygon
 The API polygon element describing the amounts of vertices in the boundary line.
 
API_Coord ** coords
 The coordinates of the vertices of the boundary line.
 
Int32 ** pends
 The polygon endings of the boundary line.
 
API_PolyArc ** parcs
 The arcs of the boundary line.
 
API_StairPolylineEdgeDataedgeData
 The edge data of each edge.
 
API_StairPolylineVertexDatavertexData
 The vertex data of each vertex.
 

Detailed Description

Represents a Stair polyline (baseline or walking line).

Remarks
There are two Stair polylines in the API_StairType structure, the baseline and the walking line.