Here is a list of all documented class members with links to the class documentation for each member:
- a -
- a : API_Gable, API_GetParamsType
- a1 : API_CWFrameType
- a2 : API_CWFrameType
- aboveLineType : API_LegacyPrefs
- aboveViewLinePen : API_BeamType, API_ColumnType, API_OpeningBaseType, API_ShellBaseType, API_WallType
- aboveViewLineType : API_BeamType, API_ColumnType, API_OpeningBaseType, API_ShellBaseType, API_WallType
- ACAPI_CreateAttributeIndex : API_AttributeIndex
- accessoryData : API_CurtainWallType
- accuracy : API_CalcAngleFormat, API_CalcAreaFormat, API_CalcLengthFormat, API_CalcVolumeFormat
- actCam : API_CamSetType
- actCamSet : API_3DProjectionInfo
- actCoord : API_RubberLineInfo
- action : API_StoryCmdType
- actionType : API_AnalyticalLoadCase
- activate3DOnChange : API_ImagingAndCalcPrefs
- activated : API_GhostRecord
- ActivateEditMode() : Tracking::Tracker
- active : API_CamSetType, API_PerspCamPars, API_SectionSegment
- activeTool : API_ToolBoxInfo
- actPageIndex : API_LayoutInfo
- actStory : API_StoryInfo
- Add() : ACAPI::MEP::v1::ReferenceSetBase
- addCustomText : API_PrintStampType
- addDateTime : API_PrintStampType
- addDispOptComb : API_PrintStampType
- AddItem() : ACAPI::Keynote::v1::KeynoteFolder, Tracking::Tracker
- additionalData : API_IOParams
- additionalPolyContourIDs : API_ElementMemo
- additionalPolyCoords : API_ElementMemo
- additionalPolyEdgeIDs : API_ElementMemo
- additionalPolyParcs : API_ElementMemo
- additionalPolyPends : API_ElementMemo
- additionalPolyVertexIDs : API_ElementMemo
- addLayerComb : API_PrintStampType
- AddLibrary() : ACAPI::Library::v1::LibraryManager
- addLoginName : API_PrintStampType
- AddNewPreference() : ACAPI::MEP::v1::CableCarrierSegmentPreferenceTable, ACAPI::MEP::v1::DuctRectangularSegmentPreferenceTable
- AddNewRow() : ACAPI::MEP::v1::DuctBranchPreferenceTable, ACAPI::MEP::v1::PipeBranchPreferenceTable
- AddNewTable() : ACAPI::MEP::v1::PreferenceTableContainerBase
- addOnInfo : API_EnvirParams
- addOwnPrefix : API_SubSet
- addPageNumber : API_PrintStampType
- addPars : API_ObjectSettingsPars
- addPolyNodeProc : API_RubberPolyCallbacks
- addPrintingScale : API_PrintStampType
- addProjectName : API_PrintStampType
- addProjectPath : API_PrintStampType
- AddSubFolder() : ACAPI::Keynote::v1::KeynoteFolder
- addViewName : API_PrintStampType
- adjustDrawingFrameToViewZoom : API_LayoutsPrefs
- adjustLevelDiffs : API_HotlinkType
- advanced : API_DimensionType
- afall : API_LghtType
- airThickness : API_WallQuantity
- alignment : API_AnalyticalCrossSection, API_RailingDistributionData
- alignTexture : API_WallType
- allColorsToBlack : API_PrintPars
- allCorners : API_ZoneAllQuantity
- allStories : API_3DFilterAndCutSettings, API_ShapePrimsParams
- altitude : API_PlaceInfo
- altitudeUnit : API_PlaceInfo
- ambientIntensity : API_SunInfo
- ambientPc : API_MaterialType
- ambientRGB : API_SunInfo
- amPartRef : API_AnalyticalReleaseDescription
- amVariationGuid : API_AnalyticalModelVariation
- analyticalEdgeLoadSettings : API_AnalyticalEdgeLoadType
- analyticalMemberType : API_AnalyticalCurveMember, API_AnalyticalSurfaceMember
- analyticalPointLoadSettings : API_AnalyticalPointLoadType
- analyticalSurfaceLoadSettings : API_AnalyticalSurfaceLoadType
- anchor : API_OpeningExtrusionParameters, API_PrimPict, API_PrimText, API_TextType
- anchorAltitude : API_OpeningExtrusionParameters
- anchorAtTextEnd : API_NoteType
- anchorLevel : API_SkylightType
- anchorPoint : API_BeamType, API_DrawingType, API_LabelType, API_NoteType, API_PictureType, API_SkylightType
- anchorPosition : API_SkylightType
- angle : API_ArcType, API_CalcUnitPrefs, API_ChangeMarkerType, API_ClipTran, API_CurtainWallType, API_CWFrameType, API_DetailType, API_DimensionPrefs, API_DrawingType, API_LevelDimensionType, API_ObjectType, API_PlaneRoofData, API_PrimArc, API_PrimText, API_RoofSegmentData, API_SFill_Arc, API_StairRiserType, API_SyTran, API_TextType, API_WallType
- angleAccuracy : API_AngleDimFormat, API_WorkingUnitPrefs
- angleDecimals : API_AngleDimFormat, API_WorkingUnitPrefs
- angleDimension : API_Element
- angleType : API_RoofSegmentData
- angleUnit : API_WorkingUnitPrefs
- API_ElemDifferenceGeneratorState() : API_ElemDifferenceGeneratorState
- API_ElemPartId() : API_ElemPartId
- API_ElemType() : API_ElemType
- API_Favorite() : API_Favorite
- API_IFCTranslatorIdentifier() : API_IFCTranslatorIdentifier
- API_MarkUpCommentType() : API_MarkUpCommentType
- API_MarkUpType() : API_MarkUpType
- API_NavigatorAddOnViewPointData() : API_NavigatorAddOnViewPointData
- API_Neig() : API_Neig
- ApplyAccessoryDefaultToToolUIData() : ACAPI::MEP::v1::AccessoryUIManager
- ApplyBendDefaultToToolUIData() : ACAPI::MEP::v1::BendUIManager
- ApplyBranchDefaultToToolUIData() : ACAPI::MEP::v1::BranchUIManager
- ApplyElementDefaultToToolUIData() : ACAPI::MEP::v1::ElementUIManager
- ApplyEquipmentDefaultToToolUIData() : ACAPI::MEP::v1::EquipmentUIManager
- ApplyFittingDefaultToToolUIData() : ACAPI::MEP::v1::FittingUIManager
- ApplyFlexibleSegmentDefaultToToolUIData() : ACAPI::MEP::v1::FlexibleSegmentUIManager
- ApplyInputPosition() : ACAPI::v1::InputHandler
- ApplyRigidSegmentDefaultToToolUIData() : ACAPI::MEP::v1::RigidSegmentUIManager
- ApplyRoutingElementDefaultToToolUIData() : ACAPI::MEP::v1::RoutingElementUIManager
- ApplyRoutingNodeDefaultToToolUIData() : ACAPI::MEP::v1::RoutingNodeUIManager
- ApplyRoutingSegmentDefaultToToolUIData() : ACAPI::MEP::v1::RoutingSegmentUIManager
- ApplyTakeOffDefaultToToolUIData() : ACAPI::MEP::v1::TakeOffUIManager
- ApplyTerminalDefaultToToolUIData() : ACAPI::MEP::v1::TerminalUIManager
- ApplyTransitionDefaultToToolUIData() : ACAPI::MEP::v1::TransitionUIManager
- arc : API_Element, API_PrimElement
- arcAngle : API_PolyArc, API_RailingRailEndType
- arcAngleMode : API_RailingRailEndType
- arcBase : API_DimensionType
- arcDiff : API_MagicWandInfo
- architect : API_ProjectNoteInfo
- archived : API_RVMChange
- archiveLib : API_FileOpenPars
- arcNumb : API_FilltypeType
- arcOrigin : API_CWSegmentType
- arcRadius : API_RailingRailEndType
- arcs : API_RoomReductionPolyType
- arcSegNumb : API_MagicWandInfo
- arcType : API_RubberArcType
- area : ACAPI::Cutaway::v1::API_CutPolygonInfo, API_BeamQuantity, API_CalcUnitPrefs, API_ColumnQuantity, API_ColumnSegmentQuantity, API_DimensionPrefs, API_RailingQuantity, API_RoomReductionPolyType, API_StairQuantity, API_StairTreadQuantity, API_WallQuantity, API_ZoneAllQuantity
- areaDecimals : API_WorkingUnitPrefs
- areaOnCursor : API_CursorSet
- areaUnit : API_WorkingUnitPrefs
- areCoordinationProfilesVisible : API_AM_VisibilitySettings
- areCrossSectionsVisible : API_AM_VisibilitySettings
- AreCuttingPlanesVisible() : ACAPI::Cutaway::v1::CuttingPlane
- areLocalCoordSystemsVisible : API_AM_VisibilitySettings
- areMembersTransparent : API_AM_VisibilitySettings
- areNodesVisible : API_AM_VisibilitySettings
- areReleasesVisible : API_AM_VisibilitySettings
- areSymbolsTransparent : API_AM_VisibilitySettings
- arrayDescriptions : API_AddParType
- arrowData : API_ArcType, API_LabelType, API_LineType, API_NoteType, API_PolyLineType, API_SplineType
- arrowPen : API_ArrowData
- arrowSize : API_ArrowData
- arrowType : API_ArrowData
- ascent : API_FontType
- assemblySegmentCuts : API_ElementMemo
- assemblySegmentData : API_BeamSegmentType, API_ColumnSegmentType
- assemblySegmentProfiles : API_ElementMemo
- assemblySegmentSchemes : API_ElementMemo
- assign : API_PropertyObjectRefType
- AssignmentsHookFunction : IFCAPI::v1::HookManager
- assignmentTable : API_IFCRelationshipData
- AssignObjects() : IFCAPI::v1::HookAssignments
- assocCWPanelsNum : API_CWFrameType
- AttributeHookFunction : IFCAPI::v1::HookManager
- attributeIds : API_AttributeFolderContent
- attributeName : API_IFCAttribute
- attributeOptions : API_DocumentFrom3DDefaults, API_DocumentFrom3DType
- attributesOn : API_SavePars_PlanDump
- attributeType : API_IFCAttribute
- attributeValue : API_IFCAttribute
- author : API_MarkUpCommentType
- autoConnectionOffset : API_RailingNodeType
- autoHotspot : API_LibPartObjectDetails
- autoNumber : API_SubSet
- autoRebuild3D : API_ImagingAndCalcPrefs
- autoSmooth : API_SplineType
- AutoTextTokenSelector : ACAPI::Keynote::v1::KeynoteManager
- auxPanelDirsNum : API_CWFrameType
- availability : API_PropertyDefinition
- available : API_LibraryInfo
- axisBase : API_RevolvedShellData
- axisDirection : API_AnalyticalCylinderSurface
- axisRotationAngle : API_ColumnType
- axisX : API_Plane3D
- axisY : API_Plane3D
- axisZ : API_Plane3D
- azimuth : API_AxonoPars, API_PerspPars
- azimuthAngle : API_SkylightType