Archicad 28 C++ API
Loading...
Searching...
No Matches
API_PrimElement Union Reference

A union containing all drawing primitives used with ACAPI_DrawingPrimitive_ShapePrims and ACAPI_LibraryPart_ShapePrims. More...

#include <APIdefs_Elements.h>

Public Attributes

API_Prim_Head header
 General primitive element header.
 
API_PrimPoint point
 A primitive point.
 
API_PrimLine line
 A primitive line.
 
API_PrimArc arc
 A primitive arc.
 
API_PrimText text
 A primitive text.
 
API_PrimPLine pline
 A primitive polyline.
 
API_PrimTri tri
 A primitive triangle.
 
API_PrimPoly poly
 A primitive polygon.
 
API_PrimPict pict
 A picture inside a placed drawing element.
 
API_CWallPanel panelKind
 The curtain wall panel is window or door type.
 

Detailed Description

A union containing all drawing primitives used with ACAPI_DrawingPrimitive_ShapePrims and ACAPI_LibraryPart_ShapePrims.