Here is a list of all documented variables with links to the class documentation for each member:
- e -
- eastings : API_GeoReferenceData
- eavesLength : API_RoofQuantity, API_ShellQuantity
- eavesOverHang : API_PolyRoofData
- eavesOverhang : API_RoofSegmentData
- ed_arrowAng : API_DimensionType
- ed_arrowFill : API_DimensionType
- ed_arrowUp : API_DimensionType
- ed_circleLevelDimensionFill : API_DimensionType
- ed_dimForm : API_DimensionType
- ed_needPlus : API_DimensionType
- ed_origin : API_DimensionType
- edge : API_Component3D
- edgeAncestry : API_RegularizedPoly
- edgeData : API_ShellContourData, API_StairBoundaryData, API_StairPolylineData
- edgeFragmentIndex : API_InternalAnalyticalMemberPartId
- edgeIDs : API_ElementMemo, API_RegularizedPoly, API_ShellContourData, API_ShellShapeData
- edgeOrVertexIdx : API_InternalAnalyticalMemberPartId
- edgeOrVertexIndex : API_AnalyticalElemPartId
- edges : API_ExportIdMappingType, API_GridMeshPolygon, API_ImportIdMappingType
- edgesNr : API_MorphQuantity
- edgesNum : API_CWPanelType
- edgeSurface : API_BeamQuantity, API_MeshQuantity, API_RoofQuantity, API_ShellQuantity, API_SlabQuantity
- edgeSurfaceLeft : API_BeamQuantity
- edgeSurfaceRight : API_BeamQuantity
- edgeTrim : API_ContourEdgeData, API_ShellBaseType
- edgeTrims : API_ElementMemo
- edgeType : API_ContourEdgeData, API_MorphType
- edition : API_IFCClassification
- editionDate : API_ClassificationSystem, API_IFCClassification
- editionVersion : API_ClassificationSystem
- effectBits : API_NoteType, API_PrimText, API_RunType, API_SectionSegment
- effects3D : API_DocumentFrom3DType
- effectsBits : API_LabelType, API_TextType
- elemCategoryValues : API_Favorite
- elemDef : API_ObjectSettingsPars
- element : API_Favorite
- elementMarker : API_Favorite
- elementRules : API_CalcRulesPrefs
- elements : API_Quantities, API_QuantitiesMask
- elementsGroupedByType : API_RoomRelation
- elementsOn : API_SavePars_PlanDump
- elementsSet : API_SavePars_Ifc
- elementsToIfcExport : API_SavePars_Ifc
- elementsToSAFExport : API_SavePars_Saf
- elementTypes : API_ConditionalElementRule
- elemGuid : API_AnalyticalCurveMember, API_AnalyticalMemberPartRef, API_AnalyticalSurfaceMember, API_ElemComponentID
- elemGUID : API_ElemPartSurfaceQuantity
- elemHead : API_NotifyElementType
- elemID : API_GridMeshHead
- elemIdx : API_TexCoordPars
- elemIndex : API_3D_Head
- elemInfoString : API_ElementMemo
- elemList : API_WindowValidatorInfo
- elemMask : API_ObjectSettingsPars
- elemPartComposites : API_Quantities
- elemPartIndex : API_Neig
- elemPartQuantities : API_Quantities
- elemPartType : API_Neig
- elemPen : API_UniformAttributeOptions
- elemSetId : API_DatabaseUnId
- elemsInMarquee : API_MarqueeFilter
- elemTypeFilter : API_3DFilterAndCutSettings
- elevation : API_DimensionPrefs, API_Element, API_RailingNodeType, API_StairTreadQuantity, API_StoryCmdType
- elevationAngle : API_SkylightType
- embodiedCarbon : API_BuildingMaterialType
- embodiedEnergy : API_BuildingMaterialType
- emissionAtt : API_MaterialType
- emissionRGB : API_MaterialType
- emptyholesSurf : API_WallQuantity
- emptyHolesSurf1 : API_WallQuantity
- emptyHolesSurf2 : API_WallQuantity
- emptyHolesVolume : API_WallQuantity
- emptySelectionBehaviour : API_AttributePickerParams
- enable2DScriptDrawingOrder : API_LibPartDoorWindowDetails, API_LibPartObjectDetails
- enabled : API_StairStructureDrainingData
- enableHideFixNamedParams : API_LibPartObjectDetails
- enableQuickSelection : API_GetPointType
- enableSaveAlert : API_FileOpenPars, API_NewProjectPars
- end : ACAPI::MEP::FlexibleSegmentPolylineLinePart
- endAng : API_ArcType, API_PrimArc
- endArrow : API_ArrowData
- endC : API_BeamType, API_CWFrameType, API_CWSegmentType, API_EditPars, API_LabelType, API_LineType, API_NoteType, API_NumberingGridLine, API_RadialDimensionType, API_SFill_Line, API_WallType
- endC2 : API_EditPars
- endConnectionType : API_AnalyticalLink_RigidSettings
- endDay : API_DailyProfileUsage
- endElementPartRef : API_AnalyticalLinkType
- endHeight : API_AssemblySegmentData
- endID : API_GridMeshEdge, API_GridMeshLine
- endIndex : API_PolyArc
- endingOffset : API_RailingNodeType
- endLine : API_SectionSegment
- endMark : API_SectionSegment
- endMarkerId : API_SectionSegment
- endMonth : API_DailyProfileUsage
- endNode : API_AnalyticalCurve
- endPlaneTilt : API_ExtrudedShellData
- endProfile : API_AnalyticalVaryingSegment
- endRel : API_CWFrameType
- endShapeEdgeData : API_ExtrudedShellData, API_RevolvedShellData, API_RuledShellData
- endsMaterial : API_BeamSegmentType, API_ColumnSegmentType
- endSurface : API_BeamSegmentQuantity
- endValue : API_AnalyticalEdgeLoad_Settings
- endWallConLength : API_RoofQuantity, API_ShellQuantity
- endWidth : API_AssemblySegmentData
- endWithID : API_CWSegmentPatternData
- engineId : API_3DStyle
- enumeratedValue : API_IFCProperty
- enumerationReference : API_IFCPropertyEnumeratedValue
- enumerationValues : API_IFCPropertyEnumeratedValue
- eolPos : API_ParagraphType
- equipmentGain : API_DailyProfile, API_HourlyProfile
- exclBlockWalls : API_SectionSegment
- exposedSurface : API_ElemPartSurfaceQuantity
- externalElem : API_Element
- externalElemData : API_ElementMemo, API_ExternalElemType
- externalLeading : API_FontType
- extraAccuracy : API_UnitConversionData
- extraBottomTread : API_StairType
- extraTopTread : API_StairType
- extrudedEdgeDatas : API_ExtrudedShellData
- extrusion : API_CWSegmentType
- extrusionGeometryData : API_OpeningType
- extrusionMaterial : API_BeamSegmentType
- extrusionStartOffset : API_OpeningExtrusionParameters
- extrusionSurfaceMaterial : API_ColumnSegmentType
- extrusionVector : API_ExtrudedShellData
- ey : API_AnalyticalCurveMember
- eyVector : API_AnalyticalCurveMember
- ez : API_AnalyticalCurveMember, API_AnalyticalSurfaceMember
- ezVector : API_AnalyticalCurveMember, API_AnalyticalSurfaceMember