Here is a list of all documented class members with links to the class documentation for each member:
- d -
- d : API_CWFrameType, API_Gable
- d3styleName : API_NavigatorView
- dailyProfileIndex : API_DailyProfileUsage
- dash : API_DashItems
- data : ACAPI::Library::v1::GSMSectionData, API_AddonObject, API_HotlinkUserData, API_LocalCoordsData, API_NavigatorAddOnViewPointData, API_StairStructureType, API_StoryInfo, API_ToolBoxInfo
- databaseID : API_DetailType
- databaseId : API_NotifyElementType
- databaseID : API_SectionSegment
- databaseUnId : API_UIStructureDisplay, API_WindowInfo
- dataHdl : API_ModulData, API_UserData
- dataVersion : ACAPI::Library::v1::GSMSectionData, API_HotlinkUserData, API_ModulData, API_UserData
- dateOfIssue : API_ProjectNoteInfo
- day : API_PlaceInfo, API_SunAngleSettings
- db : API_NavigatorItem
- dbElemIdx : API_Get3DComponentType, API_GetPointType
- dbId : API_RVMLayoutInfo
- dbSetName : API_DescriptorType, API_Obsolete_ComponentType
- DeactivateEditMode() : Tracking::Tracker
- debugGDL : API_OpenLibPartInfo
- decimals : API_CalcAngleFormat, API_CalcAreaFormat, API_CalcLengthFormat, API_CalcVolumeFormat
- defaultLabel : API_LibPartDoorWindowDetails
- defaultSubElem : API_CWFrameType, API_CWPanelType
- defaultValue : API_PropertyDefinition
- defBaluster : API_RailingBalusterSetType
- defBalusterSet : API_RailingPatternType
- defDefaultHandrail : API_RailingSegmentType
- defDefaultRail : API_RailingSegmentType
- defEdgeType : API_ShellType
- defHandrailConnection : API_RailingNodeType
- defHandrailEnd : API_RailingNodeType
- defHandrails : API_RailingSegmentType
- definedValues : API_IFCPropertyTableValue
- defineScale : API_LinetypeType
- definingValues : API_IFCPropertyTableValue
- definition : API_Property
- definitionType : API_PropertyDefinition
- defInnerPost : API_RailingPatternType
- defNode : API_RailingType
- defNote : API_DimensionType
- defPanel : API_RailingPatternType
- defPattern : API_RailingSegmentType
- defPost : API_RailingNodeType
- defRailConnection : API_RailingNodeType
- defRailEnd : API_RailingNodeType
- defRails : API_RailingSegmentType
- defSegment : API_RailingType
- defStaticDim : API_DimensionType
- defToprail : API_RailingSegmentType
- defToprailConnection : API_RailingNodeType
- defToprailEnd : API_RailingNodeType
- defWitnessForm : API_DimensionType
- defWitnessVal : API_DimensionType
- Delete() : ACAPI::MEP::v1::CableCarrierSegmentPreferenceTable, ACAPI::MEP::v1::DuctRectangularSegmentPreferenceTable, ACAPI::MEP::v1::PreferenceTableContainerBase, ACAPI::MEP::v1::ReferenceSetBase
- Delete2DScript() : ACAPI::Library::v1::GSMObject
- Delete2DVectorImage() : ACAPI::Library::v1::GSMObject
- Delete3DScript() : ACAPI::Library::v1::GSMObject
- DeleteBackwardMigrationScript() : ACAPI::Library::v1::GSMObject
- DeleteCustomSection() : ACAPI::Library::v1::GSMObject
- deletedElements : API_ElemDifference
- deletedRoutingElementId : ACAPI::MEP::RouteConnectionResult
- deleteFlag : API_CWFrameType, API_CWPanelType
- DeleteForwardMigrationScript() : ACAPI::Library::v1::GSMObject
- DeleteGDLPictures() : ACAPI::Library::v1::GSMObject
- DeleteInterfaceScript() : ACAPI::Library::v1::GSMObject
- DeleteItem() : INavigatorCallbackInterface
- DeleteMasterScript() : ACAPI::Library::v1::GSMObject
- DeleteParameterScript() : ACAPI::Library::v1::GSMObject
- DeletePreviewPicture() : ACAPI::Library::v1::GSMObject
- DeletePropertiesScript() : ACAPI::Library::v1::GSMObject
- DeleteRow() : ACAPI::MEP::v1::DuctBranchPreferenceTable, ACAPI::MEP::v1::PipeBranchPreferenceTable
- DeleteRowByReferenceIds() : ACAPI::MEP::v1::DuctBranchPreferenceTable, ACAPI::MEP::v1::PipeBranchPreferenceTable
- delPolyNodeProc : API_RubberPolyCallbacks
- density : API_BuildingMaterialType
- depth : API_CWFrameQuantity
- descent : API_FontType
- descLibInd : API_ListDataSetType
- description : API_AddOnInfo, API_AnalyticalLoadCase, API_AnalyticalLoadCombination, API_BuildingMaterialType, API_ClassificationItem, API_ClassificationSystem, API_ElemURLRef, API_GeoReferenceData, API_IFCClassification, API_Pen, API_PropertyDefinition, API_PropertyGroup, API_RVMChange, API_RVMIssue
- descriptor : API_ListData
- destBox : API_PictureType, API_PrimPict
- detail : API_Element
- detailedHoleDim : API_DimensionType
- detailIdStr : API_DetailType
- detailName : API_DetailType
- determination : API_ArcType, API_HatchType, API_LineType, API_PolyLineType, API_PrimArc, API_PrimHatchBorder, API_PrimLine, API_PrimPLine, API_PrimPoly, API_PrimTri, API_SplineType
- developerID : API_ModulID
- dfall : API_LghtType
- dhlpResourceID : API_PetPaletteType
- dialogID : API_AttributeFolderPickerParams, API_AttributePickerParams, API_UCCallbackType
- diffusePc : API_MaterialType
- dim : API_DimensionStandardsType
- dim1 : API_AddParType
- dim2 : API_AddParType
- dimAppear : API_DimensionType
- dimElems : API_ElementMemo
- dimension : API_Element
- dimForm : API_LevelDimensionType
- dimLayout : API_DimensionType
- dimName : API_NavigatorView
- dimPrefs : API_NavigatorView
- dimVal : API_AngleDimensionType, API_DimElem, API_RadialDimensionType
- dirAng : API_PerspCamPars, API_SplineDir
- directCreate : API_PictureType
- directFillet : API_RailingRailConnectionType
- direction : ACAPI::MEP::Orientation, API_AnalyticalLink_SpringSettings, API_CWFrameQuantity, API_DimensionType
- direction3D : API_DimensionType
- directionType : API_WindowType
- dirName : API_NavigatorSet
- dirVector : API_WindowType
- dirx : API_LghtType
- diry : API_LghtType
- dirz : API_LghtType
- disableDefaultFeedback : API_GetArcType, API_GetLineType, API_GetPolyType
- Dispatch() : ACAPI::API_IKeynoteFolderEventHandler, ACAPI::API_IKeynoteItemEventHandler, API_IAttributeEventHandler, API_IAttributeFolderEventHandler, API_IClassificationItemEventHandler, API_IClassificationSystemEventHandler, API_IEnableAllInfoDialogEventHandler, API_IEventHandler, API_IGraphisoftIDEventHandler, API_IMarqueeEventHandler, API_IPropertyDefinitionEventHandler, API_IPropertyGroupEventHandler, API_IWindowEventHandler
- displayId : API_NavigatorAddOnViewPointData
- displayName : API_NavigatorAddOnViewPointData
- displayOption : API_BeamType, API_ColumnType, API_CurtainWallType, API_MorphType, API_OpeningBaseType, API_ShellBaseType, API_WallType
- displayVariant : API_SingleEnumerationVariant
- dispOnSections : API_StoryCmdType, API_StoryType
- dist1 : API_LghtType
- dist2 : API_LghtType
- distance : API_PerspPars
- distanceInside : API_CurtainWallType
- distanceOutside : API_CurtainWallType
- distAreaElemPen : API_SectionSegment
- distAreaShadFill : API_SectionSegment
- distAreaShadFillBGPen : API_SectionSegment
- distAreaShadFillPen : API_SectionSegment
- distAreaUncutSurfBGPen : API_SectionSegment
- distAreaUncutSurfFillType : API_SectionSegment
- distAreaUseElemPen : API_SectionSegment
- distAreaUseUncutSurfFill : API_SectionSegment
- distortionAngle : API_RevolvedShellData
- distortionVector : API_RevolvedShellData
- distribution : API_RailingBalusterSetType, API_RailingPatternType
- dithered : API_PhotoRenderPars, API_SavePars_Picture
- ditherOnPrinter : API_PrintPars
- divArcMode : API_MagicWandInfo
- dividedLandingFixedNumOfSteps : API_StairPolylineVertexData
- dividedLandingNumOfWindersType : API_StairPolylineVertexData
- DoCalculationCallback : ACAPI::MEP::v1::GraphCalculationInterface
- docName : API_OpenLibPartInfo
- docSrc : API_DocumentFrom3DType
- docu_UName : API_LibPart
- doFrame : API_PrimHatchBorder
- domeConLength : API_RoofQuantity, API_ShellQuantity
- doNotInclude : API_SubSet
- doNotIncludeInNumbering : API_LayoutInfo
- doNotParticipateInCollDet : API_BuildingMaterialType
- dontClip : API_ShapePrimsParams
- dontRebuild : API_StoryCmdType
- door : API_Element, API_ElementQuantity, API_ElementQuantityMask, API_LibPartDetails
- doorMode : API_ModelViewOptions
- doorsSurf : API_WallQuantity, API_ZoneAllQuantity
- doorsWidth : API_WallQuantity, API_ZoneAllQuantity
- doorwindow : API_DimensionPrefs
- doubleHandrail : API_RailingHandrailType
- doublePostOffset : API_RailingInnerPostType
- doubleValue : API_IFCPropertyAnyValue, API_Variant
- draftFillBGPen : API_OverrideStyle
- draftFillFGPen : API_OverrideStyle
- draftFillType : API_OverrideStyle
- draftsmen : API_ProjectNoteInfo
- draining : API_MonolithStairStructData
- drainingFillBackGroundPen : API_StairMonolithStructureSymbolData
- drainingFillPen : API_StairMonolithStructureSymbolData
- drainingFillType : API_StairMonolithStructureSymbolData
- drainingVisible : API_MonolithPartsVisibilityData
- drawFlag : API_RubberLineInfo
- drawing : API_Element
- drawingData : API_ElementMemo
- drawingGuid : API_DrawingType, API_IOParams
- drawingModeON : API_SectionSegment
- drawingScale : API_DrawingType, API_NavigatorView
- drawingScales : API_RVMLayoutInfo
- drawRect : API_DocumentFrom3DType
- drawSegmentMode : API_PolyLineType, API_PrimPLine
- dropOffset : API_IOParams
- drvScaleCorr : API_TextLinePars
- drwIndex : API_Elem_Head, API_Prim_Head, API_PrimElemRef
- duration : API_AnalyticalLoadCase